vagrant up fails at "vmrun clone linked" step: "Error: The file is already in use". Must disable "linked" clone support.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

vagrant up fails at "vmrun clone linked" step: "Error: The file is already in use". Must disable "linked" clone support.

Lucas Rangit Magasweran
I am using Vagrant and VMware Workstation 12 Pro on Linux but cannot use a linked clone. I have to set "linked_clone = false" for my provider VM.

Since HashiCorp does not ship a 16.04 LTS box with the tag "vmware_workstation", I am using "ainfamoussyn/vagrant-vmware-xenial64". My system details are below.
  • Linux Ubuntu 16.04.3 LTS
  • Vagrant 2.0.0
  • Plugins: vagrant-vmware-workstation (5.0.1), vagrant-share (1.1.9, system)

I am using the wrong Vagrant box tag? What's the difference between "vagrant_workstation" and "vagrant_desktop"?

==> default: Enabling and configuring shared folders...
 INFO vmware_driver
: Enabling shared folders...
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]
 INFO subprocess
: Command not in installer, restoring original environment...
DEBUG subprocess
: Selecting on IO
DEBUG subprocess
: stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system
DEBUG subprocess
: Waiting for process to exit. Remaining to timeout: 32000
DEBUG subprocess
: Exit status: 255
 INFO retryable
: Retryable exception raised: #<HashiCorp::VagrantVMwareworkstation::Errors::VMRunError: An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:

Command: ["enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx", {:notify=>[:stdout, :stderr]}]

Stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system

Stderr: >
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]


--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: vagrant up fails at "vmrun clone linked" step: "Error: The file is already in use". Must disable "linked" clone support.

Alvaro Miranda Aguilera
the error is from the vm.

Please test:

Thanks
alvaro.

On Tue, Oct 31, 2017 at 12:29 AM, Lucas Rangit Magasweran <[hidden email]> wrote:
I am using Vagrant and VMware Workstation 12 Pro on Linux but cannot use a linked clone. I have to set "linked_clone = false" for my provider VM.

Since HashiCorp does not ship a 16.04 LTS box with the tag "vmware_workstation", I am using "ainfamoussyn/vagrant-vmware-xenial64". My system details are below.
  • Linux Ubuntu 16.04.3 LTS
  • Vagrant 2.0.0
  • Plugins: vagrant-vmware-workstation (5.0.1), vagrant-share (1.1.9, system)

I am using the wrong Vagrant box tag? What's the difference between "vagrant_workstation" and "vagrant_desktop"?

==> default: Enabling and configuring shared folders...
 INFO vmware_driver
: Enabling shared folders...
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]
 INFO subprocess
: Command not in installer, restoring original environment...
DEBUG subprocess
: Selecting on IO
DEBUG subprocess
: stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system
DEBUG subprocess
: Waiting for process to exit. Remaining to timeout: 32000
DEBUG subprocess
: Exit status: 255
 INFO retryable
: Retryable exception raised: #<HashiCorp::VagrantVMwareworkstation::Errors::VMRunError: An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:

Command: ["enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx", {:notify=>[:stdout, :stderr]}]

Stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system

Stderr: >
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]


--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/CAHqq0ezeLS9Nv5LFhP0V7NE7f4ahWZ3zG6iYyXm_1sPfwgxZ_w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: vagrant up fails at "vmrun clone linked" step: "Error: The file is already in use". Must disable "linked" clone support.

Lucas Rangit Magasweran
You are correct; it's a VM issue. Creating a linked clone does not fail when I use config.vm.box = "cbednarski/ubuntu-1604". I'll try and figure out why so I don't make the same mistake when I create a Vagrant box.

For now, I will work around this VM issue with:

Vagrant.configure("2") do |config|
 
...
  config
.vm.provider "vmware_workstation" do |vb|
   
...
   
if config.vm.box == "ainfamoussyn/vagrant-vmware-xenial64"
      vb
.linked_clone = false
   
end
 
end
end




On Tuesday, October 31, 2017 at 2:54:11 AM UTC-7, Alvaro Miranda Aguilera wrote:
the error is from the vm.

Please test:
<a href="https://app.vagrantup.com/cbednarski" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.vagrantup.com%2Fcbednarski\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFL8hZaQl6ea7EosjXAgmPI086QBg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.vagrantup.com%2Fcbednarski\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFL8hZaQl6ea7EosjXAgmPI086QBg&#39;;return true;">https://app.vagrantup.com/cbednarski

Thanks
alvaro.

On Tue, Oct 31, 2017 at 12:29 AM, Lucas Rangit Magasweran <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="eCEa88uSCQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">external+grou...@magasweran.com> wrote:
I am using Vagrant and VMware Workstation 12 Pro on Linux but cannot use a linked clone. I have to set "linked_clone = false" for my provider VM.

Since HashiCorp does not ship a 16.04 LTS box with the tag "vmware_workstation", I am using "ainfamoussyn/vagrant-vmware-xenial64". My system details are below.
  • Linux Ubuntu 16.04.3 LTS
  • Vagrant 2.0.0
  • Plugins: vagrant-vmware-workstation (5.0.1), vagrant-share (1.1.9, system)

I am using the wrong Vagrant box tag? What's the difference between "vagrant_workstation" and "vagrant_desktop"?

==> default: Enabling and configuring shared folders...
 INFO vmware_driver
: Enabling shared folders...
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]
 INFO subprocess
: Command not in installer, restoring original environment...
DEBUG subprocess
: Selecting on IO
DEBUG subprocess
: stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system
DEBUG subprocess
: Waiting for process to exit. Remaining to timeout: 32000
DEBUG subprocess
: Exit status: 255
 INFO retryable
: Retryable exception raised: #<HashiCorp::VagrantVMwareworkstation::Errors::VMRunError: An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:

Command: ["enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx", {:notify=>[:stdout, :stderr]}]

Stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system

Stderr: >
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]


--
This mailing list is governed under the HashiCorp Community Guidelines - <a href="https://www.hashicorp.com/community-guidelines.html" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;">https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: <a href="https://github.com/mitchellh/vagrant/issues" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;">https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="eCEa88uSCQAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">vagrant-up+...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/33624b92-c90a-4441-bb52-0425dd9fbc96%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: vagrant up fails at "vmrun clone linked" step: "Error: The file is already in use". Must disable "linked" clone support.

Lucas Rangit Magasweran
Found the root cause, the vagrant box had the *.vmx.lck file after downloading it. If I delete it first I can create a linked clone.

Is there a way to report or fix this upstream in Vagrant box https://app.vagrantup.com/ainfamoussyn/boxes/vagrant-vmware-xenial64 ?

user@host:~/src/vagrant-getting_started$ ls /opt/vagrant.d/boxes/ainfamoussyn-VAGRANTSLASH-vagrant-vmware-xenial64/1.0.0/vmware_workstation/ -l
total
6539860
-rw-r--r-- 1 user user         33 Oct 30 11:30 metadata.json
-rw-r--r-- 1 user user        169 Oct 30 11:30 Vagrantfile
-rw------- 1 user user       8684 Oct 30 11:30 vagrant-vmware-xenial64.nvram
-rw------- 1 user user 6696009728 Oct 30 11:31 vagrant-vmware-xenial64.vmdk
-rw-r--r-- 1 user user          0 Oct 30 11:31 vagrant-vmware-xenial64.vmsd
-rwxr-xr-x 1 user user       2827 Oct 30 11:31 vagrant-vmware-xenial64.vmx
-rw-r--r-- 1 user user        278 Oct 30 11:31 vagrant-vmware-xenial64.vmxf
drwxrwxr
-x 2 user user       4096 Oct 31 17:34 vagrant-vmware-xenial64.vmx.lck
-rw-r--r-- 1 user user     497503 Oct 30 11:31 vmware-0.log
-rw-r--r-- 1 user user     269743 Oct 30 11:31 vmware.log




On Tuesday, October 31, 2017 at 4:58:53 PM UTC-7, Lucas Rangit Magasweran wrote:
You are correct; it's a VM issue. Creating a linked clone does not fail when I use config.vm.box = "cbednarski/ubuntu-1604". I'll try and figure out why so I don't make the same mistake when I create a Vagrant box.

For now, I will work around this VM issue with:

Vagrant.configure("2") do |config|
 
...
  config
.vm.provider "vmware_workstation" do |vb|
   
...
   
if config.vm.box == "ainfamoussyn/vagrant-vmware-xenial64"
      vb
.linked_clone = false
   
end
 
end
end




On Tuesday, October 31, 2017 at 2:54:11 AM UTC-7, Alvaro Miranda Aguilera wrote:
the error is from the vm.

Please test:
<a href="https://app.vagrantup.com/cbednarski" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.vagrantup.com%2Fcbednarski\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFL8hZaQl6ea7EosjXAgmPI086QBg&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fapp.vagrantup.com%2Fcbednarski\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNFL8hZaQl6ea7EosjXAgmPI086QBg&#39;;return true;">https://app.vagrantup.com/cbednarski

Thanks
alvaro.

On Tue, Oct 31, 2017 at 12:29 AM, Lucas Rangit Magasweran <external+grou...@magasweran.com> wrote:
I am using Vagrant and VMware Workstation 12 Pro on Linux but cannot use a linked clone. I have to set "linked_clone = false" for my provider VM.

Since HashiCorp does not ship a 16.04 LTS box with the tag "vmware_workstation", I am using "ainfamoussyn/vagrant-vmware-xenial64". My system details are below.
  • Linux Ubuntu 16.04.3 LTS
  • Vagrant 2.0.0
  • Plugins: vagrant-vmware-workstation (5.0.1), vagrant-share (1.1.9, system)

I am using the wrong Vagrant box tag? What's the difference between "vagrant_workstation" and "vagrant_desktop"?

==> default: Enabling and configuring shared folders...
 INFO vmware_driver
: Enabling shared folders...
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]
 INFO subprocess
: Command not in installer, restoring original environment...
DEBUG subprocess
: Selecting on IO
DEBUG subprocess
: stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system
DEBUG subprocess
: Waiting for process to exit. Remaining to timeout: 32000
DEBUG subprocess
: Exit status: 255
 INFO retryable
: Retryable exception raised: #<HashiCorp::VagrantVMwareworkstation::Errors::VMRunError: An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:

Command: ["enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx", {:notify=>[:stdout, :stderr]}]

Stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system

Stderr: >
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]


--
This mailing list is governed under the HashiCorp Community Guidelines - <a href="https://www.hashicorp.com/community-guidelines.html" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;">https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: <a href="https://github.com/mitchellh/vagrant/issues" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;">https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to vagrant-up+...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com?utm_medium=email&amp;utm_source=footer" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" rel="nofollow" target="_blank" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/ffd7a8cc-4bec-4d9d-81ef-6b775730e798%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: vagrant up fails at "vmrun clone linked" step: "Error: The file is already in use". Must disable "linked" clone support.

Alvaro Miranda Aguilera
If there is no information at all how to contact the user/org then i am afraid is not possible,



Virusvrij. www.avast.com

On Wed, Nov 1, 2017 at 1:46 AM, Lucas Rangit Magasweran <[hidden email]> wrote:
Found the root cause, the vagrant box had the *.vmx.lck file after downloading it. If I delete it first I can create a linked clone.

Is there a way to report or fix this upstream in Vagrant box https://app.vagrantup.com/ainfamoussyn/boxes/vagrant-vmware-xenial64 ?

user@host:~/src/vagrant-getting_started$ ls /opt/vagrant.d/boxes/ainfamoussyn-VAGRANTSLASH-vagrant-vmware-xenial64/1.0.0/vmware_workstation/ -l
total
6539860
-rw-r--r-- 1 user user         33 Oct 30 11:30 metadata.json
-rw-r--r-- 1 user user        169 Oct 30 11:30 Vagrantfile
-rw------- 1 user user       8684 Oct 30 11:30 vagrant-vmware-xenial64.nvram
-rw------- 1 user user 6696009728 Oct 30 11:31 vagrant-vmware-xenial64.vmdk
-rw-r--r-- 1 user user          0 Oct 30 11:31 vagrant-vmware-xenial64.vmsd
-rwxr-xr-x 1 user user       2827 Oct 30 11:31 vagrant-vmware-xenial64.vmx
-rw-r--r-- 1 user user        278 Oct 30 11:31 vagrant-vmware-xenial64.vmxf
drwxrwxr
-x 2 user user       4096 Oct 31 17:34 vagrant-vmware-xenial64.vmx.lck
-rw-r--r-- 1 user user     497503 Oct 30 11:31 vmware-0.log
-rw-r--r-- 1 user user     269743 Oct 30 11:31 vmware.log




On Tuesday, October 31, 2017 at 4:58:53 PM UTC-7, Lucas Rangit Magasweran wrote:
You are correct; it's a VM issue. Creating a linked clone does not fail when I use config.vm.box = "cbednarski/ubuntu-1604". I'll try and figure out why so I don't make the same mistake when I create a Vagrant box.

For now, I will work around this VM issue with:

Vagrant.configure("2") do |config|
 
...
  config
.vm.provider "vmware_workstation" do |vb|
   
...
   
if config.vm.box == "ainfamoussyn/vagrant-vmware-xenial64"
      vb
.linked_clone = false
   
end
 
end
end




On Tuesday, October 31, 2017 at 2:54:11 AM UTC-7, Alvaro Miranda Aguilera wrote:
the error is from the vm.

Please test:

Thanks
alvaro.

On Tue, Oct 31, 2017 at 12:29 AM, Lucas Rangit Magasweran <[hidden email]om> wrote:
I am using Vagrant and VMware Workstation 12 Pro on Linux but cannot use a linked clone. I have to set "linked_clone = false" for my provider VM.

Since HashiCorp does not ship a 16.04 LTS box with the tag "vmware_workstation", I am using "ainfamoussyn/vagrant-vmware-xenial64". My system details are below.
  • Linux Ubuntu 16.04.3 LTS
  • Vagrant 2.0.0
  • Plugins: vagrant-vmware-workstation (5.0.1), vagrant-share (1.1.9, system)

I am using the wrong Vagrant box tag? What's the difference between "vagrant_workstation" and "vagrant_desktop"?

==> default: Enabling and configuring shared folders...
 INFO vmware_driver
: Enabling shared folders...
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]
 INFO subprocess
: Command not in installer, restoring original environment...
DEBUG subprocess
: Selecting on IO
DEBUG subprocess
: stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system
DEBUG subprocess
: Waiting for process to exit. Remaining to timeout: 32000
DEBUG subprocess
: Exit status: 255
 INFO retryable
: Retryable exception raised: #<HashiCorp::VagrantVMwareworkstation::Errors::VMRunError: An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:

Command: ["enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx", {:notify=>[:stdout, :stderr]}]

Stdout: Error: There was an error mounting the Shared Folders file system inside the guest operating system

Stderr: >
 INFO subprocess
: Starting process: ["/usr/bin/vmrun", "enableSharedFolders", "/home/user/src/vagrant-getting_started/.vagrant/machines/default/vmware_workstation/6f1ea773-2c51-4798-81ee-73ec811253f6/vagrant-vmware-xenial64.vmx"]


--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email]m.
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/4f57376e-2d14-4b13-8eb9-9d29ced4019a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/ffd7a8cc-4bec-4d9d-81ef-6b775730e798%40googlegroups.com.

For more options, visit https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/CAHqq0exktx%2B2YngH%2Bi0x4v2mDOFu562agchQYBsxyP6T3-y2OQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.