vagrant-aws install errors on Mac

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

vagrant-aws install errors on Mac

Michael Waldrop
I'm a bit new to vagrant and very thin on Ruby experience.  I've been trying to add the vagrant-aws plugin to vagrant on a mac and get the following error:

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
/Applications/Vagrant/embedded/lib/ruby/1.9.1/rubygems/installer.rb:562:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
        /Applications/Vagrant/embedded/bin/ruby extconf.rb
checking for libxml/parser.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

It appears that this is an error related to a missing ruby development environment.  Do I have to get external resources outside of the vagrant project to enable this plugin ?

Thanks for any help.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: vagrant-aws install errors on Mac

Cassiano Leal
I've just tried it now and it compiles without a problem here. Do you have the latest XCode installed?

- cassiano

On Friday, April 19, 2013 at 09:32, Michael Waldrop wrote:

I'm a bit new to vagrant and very thin on Ruby experience.  I've been trying to add the vagrant-aws plugin to vagrant on a mac and get the following error:

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
/Applications/Vagrant/embedded/lib/ruby/1.9.1/rubygems/installer.rb:562:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
        /Applications/Vagrant/embedded/bin/ruby extconf.rb
checking for libxml/parser.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

It appears that this is an error related to a missing ruby development environment.  Do I have to get external resources outside of the vagrant project to enable this plugin ?

Thanks for any help.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: vagrant-aws install errors on Mac

Michael Waldrop
I do not, but that is easy enough to do.

On Friday, April 19, 2013 12:48:24 PM UTC-4, Cassiano Leal wrote:
I've just tried it now and it compiles without a problem here. Do you have the latest XCode installed?

- cassiano

On Friday, April 19, 2013 at 09:32, Michael Waldrop wrote:

I'm a bit new to vagrant and very thin on Ruby experience.  I've been trying to add the vagrant-aws plugin to vagrant on a mac and get the following error:

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
/Applications/Vagrant/embedded/lib/ruby/1.9.1/rubygems/installer.rb:562:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
        /Applications/Vagrant/embedded/bin/ruby extconf.rb
checking for libxml/parser.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

It appears that this is an error related to a missing ruby development environment.  Do I have to get external resources outside of the vagrant project to enable this plugin ?

Thanks for any help.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="i-eQDPz3NP8J">vagrant-up+...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: vagrant-aws install errors on Mac

Michael Waldrop
In reply to this post by Michael Waldrop
Same error with Xcode installed.

On Friday, April 19, 2013 8:32:16 AM UTC-4, Michael Waldrop wrote:
I'm a bit new to vagrant and very thin on Ruby experience.  I've been trying to add the vagrant-aws plugin to vagrant on a mac and get the following error:

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
/Applications/Vagrant/embedded/lib/ruby/1.9.1/rubygems/installer.rb:562:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
        /Applications/Vagrant/embedded/bin/ruby extconf.rb
checking for libxml/parser.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

It appears that this is an error related to a missing ruby development environment.  Do I have to get external resources outside of the vagrant project to enable this plugin ?

Thanks for any help.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: vagrant-aws install errors on Mac

Cassiano Leal
Install XCode's command line tools:

Open XCode -> Preferences -> Downloads -> Components -> Command Line Tools -> press "Install"

If that doesn't work, try to find the mkmf.log file mentioned in the error. That might give you more clues.

- cassiano

On Friday, April 19, 2013 at 16:25, Michael Waldrop wrote:

Same error with Xcode installed.

On Friday, April 19, 2013 8:32:16 AM UTC-4, Michael Waldrop wrote:
I'm a bit new to vagrant and very thin on Ruby experience.  I've been trying to add the vagrant-aws plugin to vagrant on a mac and get the following error:

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
/Applications/Vagrant/embedded/lib/ruby/1.9.1/rubygems/installer.rb:562:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
        /Applications/Vagrant/embedded/bin/ruby extconf.rb
checking for libxml/parser.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

It appears that this is an error related to a missing ruby development environment.  Do I have to get external resources outside of the vagrant project to enable this plugin ?

Thanks for any help.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: vagrant-aws install errors on Mac

Michael Waldrop
Worked !  Thank you !

On Friday, April 19, 2013 3:28:57 PM UTC-4, Cassiano Leal wrote:
Install XCode's command line tools:

Open XCode -> Preferences -> Downloads -> Components -> Command Line Tools -> press "Install"

If that doesn't work, try to find the mkmf.log file mentioned in the error. That might give you more clues.

- cassiano

On Friday, April 19, 2013 at 16:25, Michael Waldrop wrote:

Same error with Xcode installed.

On Friday, April 19, 2013 8:32:16 AM UTC-4, Michael Waldrop wrote:
I'm a bit new to vagrant and very thin on Ruby experience.  I've been trying to add the vagrant-aws plugin to vagrant on a mac and get the following error:

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
/Applications/Vagrant/embedded/lib/ruby/1.9.1/rubygems/installer.rb:562:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
        /Applications/Vagrant/embedded/bin/ruby extconf.rb
checking for libxml/parser.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

It appears that this is an error related to a missing ruby development environment.  Do I have to get external resources outside of the vagrant project to enable this plugin ?

Thanks for any help.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="pRl6eHYFcNEJ">vagrant-up+...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: vagrant-aws install errors on Mac

Cassiano Leal
You're welcome. Always go this route before anything else when compiling things under OS X. :)

- cassiano

On Friday, April 19, 2013 at 16:37, Michael Waldrop wrote:

Worked !  Thank you !

On Friday, April 19, 2013 3:28:57 PM UTC-4, Cassiano Leal wrote:
Install XCode's command line tools:

Open XCode -> Preferences -> Downloads -> Components -> Command Line Tools -> press "Install"

If that doesn't work, try to find the mkmf.log file mentioned in the error. That might give you more clues.

- cassiano

On Friday, April 19, 2013 at 16:25, Michael Waldrop wrote:

Same error with Xcode installed.

On Friday, April 19, 2013 8:32:16 AM UTC-4, Michael Waldrop wrote:
I'm a bit new to vagrant and very thin on Ruby experience.  I've been trying to add the vagrant-aws plugin to vagrant on a mac and get the following error:

$ vagrant plugin install vagrant-aws
Installing the 'vagrant-aws' plugin. This can take a few minutes...
/Applications/Vagrant/embedded/lib/ruby/1.9.1/rubygems/installer.rb:562:in `rescue in block in build_extensions': ERROR: Failed to build gem native extension. (Gem::Installer::ExtensionBuildError)
        /Applications/Vagrant/embedded/bin/ruby extconf.rb
checking for libxml/parser.h... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers.  Check the mkmf.log file for more
details.  You may need configuration options.

It appears that this is an error related to a missing ruby development environment.  Do I have to get external resources outside of the vagrant project to enable this plugin ?

Thanks for any help.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="pRl6eHYFcNEJ">vagrant-up+...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.