problem with my vagrant installation.

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with my vagrant installation.

Vagrant mailing list
hi everyone

i uploaded vagrant on top of my vagrant box. however when i do a simple vagrant command i get the following error message;   


$ vagrant
C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb                                                                                                                :54:in `require': cannot load such file -- vagrant-share/helper/api (LoadError)
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:244:in `<encoded>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `RGLoader_load'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `<top (required)>'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share.rb:23:in `block in <class:Plugin>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.4/lib/vagrant/c                          



i have tried to remove vagrant and re-install but i keep getting the same message.

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/3408bb35-2988-4ed1-87e3-6da0b9d93d16%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: problem with my vagrant installation.

Alvaro Miranda Aguilera

On Sat, May 13, 2017 at 3:56 PM, 'paul kendal' via Vagrant <[hidden email]> wrote:
ant-share-1.1.7

Hello

Can you reinstall?

Uninstall

then delete 
C:/HashiCorp/Vagrant/

and .vagrant.d on your home,

Thanks
Alvaro.

--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/CAHqq0eyhV0DC-2sY4hv7tzeCq1%3D4M9E6_5zc1dM6D%2B2t7CksKQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: problem with my vagrant installation.

Vagrant mailing list

Hello Alvaro

thanks for your advice. i did try it. i.e i deleted everything and reinstalled vagrant. but i still get the following message:


$ vagrant
C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb                                                                                                                :54:in `require': cannot load such file -- vagrant-share/helper/api (LoadError)
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:244:in `<encoded>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `RGLoader_load'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `<top (required)>'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share.rb:23:in `block in <class:Plugin>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.4/lib/vagrant/c                                                                                                                li.rb:75:in `call'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.4/lib/vagrant/c                                                                                                                li.rb:75:in `block (2 levels) in help'


do you have any idea what this message means and why it does not work on my laptop?

i am using windows 8 

thanks you 



On Saturday, May 13, 2017 at 5:57:50 PM UTC+1, Alvaro Miranda Aguilera wrote:

On Sat, May 13, 2017 at 3:56 PM, 'paul kendal' via Vagrant <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="JzlWw_a4BAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">vagra...@...> wrote:
ant-share-1.1.7

Hello

Can you reinstall?

Uninstall

then delete 
C:/HashiCorp/Vagrant/

and .vagrant.d on your home,

Thanks
Alvaro.

--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/94e0667d-9419-4a2d-9bfe-c9e6530cae6a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: problem with my vagrant installation.

Alvaro Miranda Aguilera
does this happen with a sample Vagrantfile?

mkdir precise64
cd precise64
vagrant init -m hashicorp/precise64
vagrant up

?


On Sun, May 14, 2017 at 11:23 AM, 'paul kendal' via Vagrant <[hidden email]> wrote:

Hello Alvaro

thanks for your advice. i did try it. i.e i deleted everything and reinstalled vagrant. but i still get the following message:


$ vagrant
C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb                                                                                                                :54:in `require': cannot load such file -- vagrant-share/helper/api (LoadError)
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:244:in `<encoded>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `RGLoader_load'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `<top (required)>'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share.rb:23:in `block in <class:Plugin>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.4/lib/vagrant/c                                                                                                                li.rb:75:in `call'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.4/lib/vagrant/c                                                                                                                li.rb:75:in `block (2 levels) in help'


do you have any idea what this message means and why it does not work on my laptop?

i am using windows 8 

thanks you 



On Saturday, May 13, 2017 at 5:57:50 PM UTC+1, Alvaro Miranda Aguilera wrote:

On Sat, May 13, 2017 at 3:56 PM, 'paul kendal' via Vagrant <[hidden email]> wrote:
ant-share-1.1.7

Hello

Can you reinstall?

Uninstall

then delete 
C:/HashiCorp/Vagrant/

and .vagrant.d on your home,

Thanks
Alvaro.

--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/94e0667d-9419-4a2d-9bfe-c9e6530cae6a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/CAHqq0ewUnyQAWKeNigdjU-3v7DMyWWJmPtpWFffVZZsdJMv67A%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: problem with my vagrant installation.

Ian Koenig
In reply to this post by Vagrant mailing list
Is this happening with vagrant 1.9.5?   That fixed my issue like this on Windows 10.  

On Sunday, 14 May 2017 04:23:38 UTC-5, paul kendal wrote:

Hello Alvaro

thanks for your advice. i did try it. i.e i deleted everything and reinstalled vagrant. but i still get the following message:


$ vagrant
C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb                                                                                                                :54:in `require': cannot load such file -- vagrant-share/helper/api (LoadError)
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:244:in `<encoded>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `RGLoader_load'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share/activate.rb:16:in `<top (required)>'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kern                                                                                                                el_require.rb:54:in `require'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-share-1.1.7/lib/vag                                                                                                                rant-share.rb:23:in `block in <class:Plugin>'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.4/lib/vagrant/c                                                                                                                li.rb:75:in `call'
        from C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.9.4/lib/vagrant/c                                                                                                                li.rb:75:in `block (2 levels) in help'


do you have any idea what this message means and why it does not work on my laptop?

i am using windows 8 

thanks you 



On Saturday, May 13, 2017 at 5:57:50 PM UTC+1, Alvaro Miranda Aguilera wrote:

On Sat, May 13, 2017 at 3:56 PM, 'paul kendal' via Vagrant <[hidden email]> wrote:
ant-share-1.1.7

Hello

Can you reinstall?

Uninstall

then delete 
C:/HashiCorp/Vagrant/

and .vagrant.d on your home,

Thanks
Alvaro.

--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/50e7e8aa-6a28-4180-81d1-cac8cbea4bad%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.