Vagrant with VMware Fusion Technology Preview

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Vagrant with VMware Fusion Technology Preview

VMTrooper
Has anyone gotten Vagrant to run with the Fusion Technology Preview?  I understand that this release is not supported by Vagrant, but I'd like to run this release to work with Raring (Ubuntu 13.04).  VMware Fusion 5 doesn't support it yet, and when I tried to cobble together a Vagrant box for Fusion 5, the Folder Sharing did not work.

When I try vagrant up, I get the following message:

This provider only works with VMware Fusion 5.x. You have
Fusion ''. Please install the proper version of VMware
Fusion and try again.

Is there a way to, umm, encourage Vagrant to believe that I am running Fusion 5.0 or to not even check the version number?

Thanks,
Trevor

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant with VMware Fusion Technology Preview

Mitchell Hashimoto
Trevor,

There is no way to force this.

Best,
Mitchell

On Sat, Jul 20, 2013 at 11:57 PM, Trevor Roberts <[hidden email]> wrote:

> Has anyone gotten Vagrant to run with the Fusion Technology Preview?  I
> understand that this release is not supported by Vagrant, but I'd like to
> run this release to work with Raring (Ubuntu 13.04).  VMware Fusion 5
> doesn't support it yet, and when I tried to cobble together a Vagrant box
> for Fusion 5, the Folder Sharing did not work.
>
> When I try vagrant up, I get the following message:
>
> This provider only works with VMware Fusion 5.x. You have
> Fusion ''. Please install the proper version of VMware
> Fusion and try again.
>
> Is there a way to, umm, encourage Vagrant to believe that I am running
> Fusion 5.0 or to not even check the version number?
>
> Thanks,
> Trevor
>
> --
> You received this message because you are subscribed to the Google Groups
> "Vagrant" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/groups/opt_out.
>
>

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.


Reply | Threaded
Open this post in threaded view
|

Re: Vagrant with VMware Fusion Technology Preview

Dave Martorana
In reply to this post by VMTrooper
Hi Trevor!

We finally got a 13.04 box working on VMware Fusion 5.x. Deets are here, as is the dl link for the box:

http://tech.flyclops.com/ubuntu-13-04-raring-base-box-for-vmware-fusion-provider-342

Cheers,

Dave

On Sunday, July 21, 2013 2:57:15 AM UTC-4, Trevor Roberts wrote:
Has anyone gotten Vagrant to run with the Fusion Technology Preview?  I understand that this release is not supported by Vagrant, but I'd like to run this release to work with Raring (Ubuntu 13.04).  VMware Fusion 5 doesn't support it yet, and when I tried to cobble together a Vagrant box for Fusion 5, the Folder Sharing did not work.

When I try vagrant up, I get the following message:

This provider only works with VMware Fusion 5.x. You have
Fusion ''. Please install the proper version of VMware
Fusion and try again.

Is there a way to, umm, encourage Vagrant to believe that I am running Fusion 5.0 or to not even check the version number?

Thanks,
Trevor

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant with VMware Fusion Technology Preview

VMTrooper
That's great news, Dave!

Thank you so much for sharing.  If you have not done so already, would you consider reaching out to the http://www.vagrantbox.es/ folks so that they can list your work?

It would be great to help build the Fusion community for Vagrant.

Interestingly enough, I followed steps similar to what you listed, but I did them manually instead using the scripts.  The shared folders worked fine before I converted the VM to a box, but then vagrant up wasn't happy.

Glad you guys got past that barrier!

Thanks again,
Trevor

On Thursday, July 25, 2013 3:21:57 PM UTC-7, Dave Martorana wrote:
Hi Trevor!

We finally got a 13.04 box working on VMware Fusion 5.x. Deets are here, as is the dl link for the box:


Cheers,

Dave

On Sunday, July 21, 2013 2:57:15 AM UTC-4, Trevor Roberts wrote:
Has anyone gotten Vagrant to run with the Fusion Technology Preview?  I understand that this release is not supported by Vagrant, but I'd like to run this release to work with Raring (Ubuntu 13.04).  VMware Fusion 5 doesn't support it yet, and when I tried to cobble together a Vagrant box for Fusion 5, the Folder Sharing did not work.

When I try vagrant up, I get the following message:

This provider only works with VMware Fusion 5.x. You have
Fusion ''. Please install the proper version of VMware
Fusion and try again.

Is there a way to, umm, encourage Vagrant to believe that I am running Fusion 5.0 or to not even check the version number?

Thanks,
Trevor

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant with VMware Fusion Technology Preview

Dave Martorana
Hi Trevor,

My only concern with that is the costs of hosting the box - each download would cost us around $0.15. Any thoughts on what might be a good place to host the download that would be cheaper than S3? I’d be happy to put it on vagrantbox.es.

Cheers,

Dave


On Fri, Jul 26, 2013 at 12:33 PM, Trevor Roberts <[hidden email]> wrote:
That's great news, Dave!

Thank you so much for sharing.  If you have not done so already, would you consider reaching out to the http://www.vagrantbox.es/ folks so that they can list your work?

It would be great to help build the Fusion community for Vagrant.

Interestingly enough, I followed steps similar to what you listed, but I did them manually instead using the scripts.  The shared folders worked fine before I converted the VM to a box, but then vagrant up wasn't happy.

Glad you guys got past that barrier!

Thanks again,
Trevor


On Thursday, July 25, 2013 3:21:57 PM UTC-7, Dave Martorana wrote:
Hi Trevor!

We finally got a 13.04 box working on VMware Fusion 5.x. Deets are here, as is the dl link for the box:


Cheers,

Dave

On Sunday, July 21, 2013 2:57:15 AM UTC-4, Trevor Roberts wrote:
Has anyone gotten Vagrant to run with the Fusion Technology Preview?  I understand that this release is not supported by Vagrant, but I'd like to run this release to work with Raring (Ubuntu 13.04).  VMware Fusion 5 doesn't support it yet, and when I tried to cobble together a Vagrant box for Fusion 5, the Folder Sharing did not work.

When I try vagrant up, I get the following message:

This provider only works with VMware Fusion 5.x. You have
Fusion ''. Please install the proper version of VMware
Fusion and try again.

Is there a way to, umm, encourage Vagrant to believe that I am running Fusion 5.0 or to not even check the version number?

Thanks,
Trevor

--
You received this message because you are subscribed to a topic in the Google Groups "Vagrant" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/vagrant-up/iRjUT3eHNaM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant with VMware Fusion Technology Preview

VMTrooper
Yeah, that's a big concern!  Well, thank you for the 0.15 for my download. :-)  I'm not sure what would be a cheaper solution.  Maybe the site admins there can make a suggestion?

On Friday, July 26, 2013 12:22:55 PM UTC-7, Dave Martorana wrote:
Hi Trevor,

My only concern with that is the costs of hosting the box - each download would cost us around $0.15. Any thoughts on what might be a good place to host the download that would be cheaper than S3? I’d be happy to put it on vagrantbox.es.

Cheers,

Dave


On Fri, Jul 26, 2013 at 12:33 PM, Trevor Roberts <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="JKlmcYP3B-0J">vmtr...@...> wrote:
That's great news, Dave!

Thank you so much for sharing.  If you have not done so already, would you consider reaching out to the http://www.vagrantbox.es/ folks so that they can list your work?

It would be great to help build the Fusion community for Vagrant.

Interestingly enough, I followed steps similar to what you listed, but I did them manually instead using the scripts.  The shared folders worked fine before I converted the VM to a box, but then vagrant up wasn't happy.

Glad you guys got past that barrier!

Thanks again,
Trevor


On Thursday, July 25, 2013 3:21:57 PM UTC-7, Dave Martorana wrote:
Hi Trevor!

We finally got a 13.04 box working on VMware Fusion 5.x. Deets are here, as is the dl link for the box:


Cheers,

Dave

On Sunday, July 21, 2013 2:57:15 AM UTC-4, Trevor Roberts wrote:
Has anyone gotten Vagrant to run with the Fusion Technology Preview?  I understand that this release is not supported by Vagrant, but I'd like to run this release to work with Raring (Ubuntu 13.04).  VMware Fusion 5 doesn't support it yet, and when I tried to cobble together a Vagrant box for Fusion 5, the Folder Sharing did not work.

When I try vagrant up, I get the following message:

This provider only works with VMware Fusion 5.x. You have
Fusion ''. Please install the proper version of VMware
Fusion and try again.

Is there a way to, umm, encourage Vagrant to believe that I am running Fusion 5.0 or to not even check the version number?

Thanks,
Trevor

--
You received this message because you are subscribed to a topic in the Google Groups "Vagrant" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/vagrant-up/iRjUT3eHNaM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="JKlmcYP3B-0J">vagrant-up+...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.