Vagrant rackspace plugin install fails

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Vagrant rackspace plugin install fails

Nathan Nobbe

Hi,

I'm trying to install the rackspace plugin for vagrant (1.5.1):

vagrant plugin install vagrant-rackspace

But it complains

Bundler, the underlying system Vagrant uses to install plugins, reported an error. The error is shown below. These errors are usually caused by misconfigured plugin installations or transient network issues. The error from Bundler is:

An error occurred while installing nokogiri (1.6.1), and Bundler cannot continue. Make sure that gem install nokogiri -v '1.6.1' succeeds before bundling.

However gem install nokogiri -v '1.6.1' and cd /Applications/Vagrant/embedded/bin && ./gem install nokogiri -v '1.6.1' both work.

I've looked at a bunch of SO threads and blog posts. Things I've tried that have not worked

  1. Running xcode-select --install
  2. Installing full xcode
  3. brew install gcc-4.2
  4. Remove rvm and rvm version of ruby
  5. Install nokogiri w/ built-in (mac) ruby and vagrant-embedded ruby

Despite the fact that nokogiri installs fine (#5 above) without sudo on both counts, vagrant plugin install vagrant-rackspace still fails...

So, in summary, I can install the nokogiri plugin (with vagrant-bundled ruby), however I cannot install the vagrant rackspace plugin. It appears to be a problem with Bundler, but I can't figure it out.

Full output of vagrant plugin install vagrant-rackspace --debug

Your help appreciated,

-nathan

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Vagrant rackspace plugin install fails

VMTrooper
Have you checked the GitHub page for the plugin?  Someone else there may have run into the same issue.

If not, you should open a bug on the dev's repo so that someone can look into it

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.