Vagrant not creating / configuring host networks

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Vagrant not creating / configuring host networks

John Harris
Not a big user of Vagrant so maybe doing / expecting something wrong, but as far as I understand Vagrant should create & configure host networks. In virtualbox > preferences > networks I have nothing for NAT or host-only.

$ ifconfig
docker0   Link encap:Ethernet  HWaddr 02:42:ff:a3:56:af  
          inet addr:172.17.0.1  Bcast:0.0.0.0  Mask:255.255.0.0
          inet6 addr: fe80::42:ffff:fea3:56af/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:418215 errors:0 dropped:0 overruns:0 frame:0
          TX packets:377471 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:33694375 (33.6 MB)  TX bytes:78667334 (78.6 MB)

eth0      Link encap:Ethernet  HWaddr 54:ee:75:16:e9:2e  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:b2a00000-b2a20000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2654653 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2654653 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:688746243 (688.7 MB)  TX bytes:688746243 (688.7 MB)

wlan0     Link encap:Ethernet  HWaddr e8:2a:ea:30:82:84  
          inet addr:192.168.7.112  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fe80::ea2a:eaff:fe30:8284/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:92676204 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60523045 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:111838067710 (111.8 GB)  TX bytes:13136097499 (13.1 GB)


In my Vagrantfile:

...
s.vm.network :private_network, :ip => "172.42.42.101", :netmask => "255.255.255.0", :auto_config => true, virtualbox__intnet: "k8s-net"
...

After `vagrant up` my VM is up, `ifconfig` in the VM shows the IP as 172.42.42.101 but `ifconfig` on the host doesn't show any additional interfaces and both NAT and host-only in Virtualbox are also still empty.

Virtualbox version 5.1.22
Vagrant version 1.9.5

Is this a bug / issue or am I doing something wrong?

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/b4ee7ab1-ba66-46c6-b1ed-11b063a831ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Vagrant not creating / configuring host networks

pixel fairy
can you show us the whole vagrant file, or a minimal one that has the issue?

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.

GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/4a0fb201-9167-4358-8d01-bf5ed13c5d5f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant not creating / configuring host networks

Alvaro Miranda Aguilera
In reply to this post by John Harris
hello

seems thats from the host.

Can you share the same from the guest?

Also a full repo to run vagrant up on our side will help to troubleshoot.

Alvaro.

On Tue, May 30, 2017 at 7:25 PM, John Harris <[hidden email]> wrote:
Not a big user of Vagrant so maybe doing / expecting something wrong, but as far as I understand Vagrant should create & configure host networks. In virtualbox > preferences > networks I have nothing for NAT or host-only.

$ ifconfig
docker0   Link encap:Ethernet  HWaddr 02:42:ff:a3:56:af  
          inet addr:172.17.0.1  Bcast:0.0.0.0  Mask:255.255.0.0
          inet6 addr: fe80::42:ffff:fea3:56af/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:418215 errors:0 dropped:0 overruns:0 frame:0
          TX packets:377471 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:33694375 (33.6 MB)  TX bytes:78667334 (78.6 MB)

eth0      Link encap:Ethernet  HWaddr 54:ee:75:16:e9:2e  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:20 Memory:b2a00000-b2a20000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2654653 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2654653 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:688746243 (688.7 MB)  TX bytes:688746243 (688.7 MB)

wlan0     Link encap:Ethernet  HWaddr e8:2a:ea:30:82:84  
          inet addr:192.168.7.112  Bcast:192.168.7.255  Mask:255.255.255.0
          inet6 addr: fe80::ea2a:eaff:fe30:8284/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:92676204 errors:0 dropped:0 overruns:0 frame:0
          TX packets:60523045 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:111838067710 (111.8 GB)  TX bytes:13136097499 (13.1 GB)


In my Vagrantfile:

...
s.vm.network :private_network, :ip => "172.42.42.101", :netmask => "255.255.255.0", :auto_config => true, virtualbox__intnet: "k8s-net"
...

After `vagrant up` my VM is up, `ifconfig` in the VM shows the IP as 172.42.42.101 but `ifconfig` on the host doesn't show any additional interfaces and both NAT and host-only in Virtualbox are also still empty.

Virtualbox version 5.1.22
Vagrant version 1.9.5

Is this a bug / issue or am I doing something wrong?

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/b4ee7ab1-ba66-46c6-b1ed-11b063a831ba%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/CAHqq0exiv2dp-QO6E%2BXQkfih957xRo%2BkDdw62PNCi-fB8tueJw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.