Vagrant Up not working behind proxy.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Vagrant Up not working behind proxy.

Manish Mehra
Hi Team

I am working in a corporate proxy environment. I followed the steps given under "http://swaeku.github.io/blog/2013/03/09/installing-vagrant-on-ubuntu-12-dot-10/" to install a new virtual box in my machine but I got following error:
"Timed out while waiting for the machine to boot. This means that
Vagrant was unable to communicate with the guest machine within
the configured ("config.vm.boot_timeout" value) time period. This can
mean a number of things.

If you're using a custom box, make sure that networking is properly
working and you're able to connect to the machine. It is a common
problem that networking isn't setup properly in these boxes.
Verify that authentication configurations are also setup properly,
as well.

If the box appears to be booting properly, you may want to increase
the timeout ("config.vm.boot_timeout") value."

Please guide me.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant Up not working behind proxy.

Torben Knerr
Hi Manish,

you might wanna have a look at the
https://github.com/tmatilai/vagrant-proxyconf plugin, which configures
the proxy on the guest machine.

Also make sure you have the `http_proxy` and `https_proxy` env vars
set on the host.

HTH,
Torben



On Mon, Aug 25, 2014 at 11:22 AM, Manish Mehra <[hidden email]> wrote:

> Hi Team
>
> I am working in a corporate proxy environment. I followed the steps given
> under
> "http://swaeku.github.io/blog/2013/03/09/installing-vagrant-on-ubuntu-12-dot-10/"
> to install a new virtual box in my machine but I got following error:
> "Timed out while waiting for the machine to boot. This means that
> Vagrant was unable to communicate with the guest machine within
> the configured ("config.vm.boot_timeout" value) time period. This can
> mean a number of things.
>
> If you're using a custom box, make sure that networking is properly
> working and you're able to connect to the machine. It is a common
> problem that networking isn't setup properly in these boxes.
> Verify that authentication configurations are also setup properly,
> as well.
>
> If the box appears to be booting properly, you may want to increase
> the timeout ("config.vm.boot_timeout") value."
>
> Please guide me.
>
> --
> You received this message because you are subscribed to the Google Groups
> "Vagrant" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [hidden email].
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.