Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

Ian Koenig

Hi,

I'm running into an issue with the Vagrant Plugin for VMware on Windows 10.

  • VMware Workstation Pro 12.5.6 
  • Vagrant 1.9.5 
  • VMware Workstation Plugin 4.0.19

My Vagrantfile:

BOX_IMAGE = "centos/7"
Vagrant.configure("2") do |config|
    config
.vm.define "service" do |subconfig|
       subconfig
.vm.box = BOX_IMAGE
       subconfig
.vm.hostname = "service"
       subconfig
.vm.network :private_network, ip: "192.168.47.50"
   
end
end


When I do a vagrant up, it gives an error of

======== 

==> service: Setting hostname... 

The following SSH command responded with a non-zero exit status. 

Vagrant assumes that this means the command failed!

# Update sysconfig 

sed -i 's/\(HOSTNAME=\).*/\1service/' /etc/sysconfig/network

# Update DNS 

sed -i 's/\(DHCP_HOSTNAME=\).*/\1"service"/' /etc/sysconfig/network-scripts/ifcfg-*

# Set the hostname - use hostnamectl if available 

echo 'service' > /etc/hostname 

if command -v hostnamectl; then 

hostnamectl set-hostname --static 'service' 

hostnamectl set-hostname --transient 'service' 

else 

hostname -F /etc/hostname 

fi

# Prepend ourselves to /etc/hosts 

grep -w 'service' /etc/hosts || { 

sed -i'' '1i 127.0.0.1\tservice\tservice' /etc/hosts 

}

# Restart network 

service network restart

Stdout from the command:

/bin/hostnamectl 

Restarting network (via systemctl): [FAILED]

Stderr from the command:

Job for network.service failed because the control process exited with error code. See "systemctl status network.service 

" and "journalctl -xe" for details. 

===============


What I see is in the settings for that VM, it is setup for the private_network adapter to be set to say "vmnet19". The adapter in VMware Workstation is named "VMnet19" which is case sensitive. If I change the adapter to be "VMnet19" in the VMX file, it works as expected.


Any thoughts on how to fix it or when VMware Workstation broke it?  



--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/94a29935-889d-4ffe-a8f9-da7d3b852c47%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

Alvaro Miranda Aguilera
Hello

Can you send an email to support @ hashicorp.com ?

Thanks
alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/CAHqq0ezxxVXCwHz5Y466PP1nDW6hm1t25%2BvoX4hNPeHwdg_FnQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

Ian Koenig
Thanks.  Ticket #3782 made on this.


On Monday, 5 June 2017 04:08:28 UTC-5, Alvaro Miranda Aguilera wrote:
Hello

Can you send an email to support @ <a href="http://hashicorp.com" target="_blank" rel="nofollow" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;">hashicorp.com ?

Thanks
alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/6178bbf7-9c2b-4bd6-a547-93ec541f1387%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

Ian Koenig
There's been zero movement other than having someone assigned.  What can we do to have someone engage on this?  


On Monday, 5 June 2017 10:47:53 UTC-5, Ian Koenig wrote:
Thanks.  Ticket #3782 made on this.


On Monday, 5 June 2017 04:08:28 UTC-5, Alvaro Miranda Aguilera wrote:
Hello

Can you send an email to support @ <a href="http://hashicorp.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;">hashicorp.com ?

Thanks
alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/8189ef9e-e350-4375-a4e0-792d96691461%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

Ian Koenig
How can I get this moving Alvaro?   This is holding up a potentially decent sized order of vagrant-vmware-workstation plugin.   We can't use virtualbox in our environment due to other security software we utilize (it causes virtualbox to BSOD the windows systems) and the capabilities that vagrant offers is HUGE for what we are doing.   VMware Workstation doesn't trigger this BSOD in my testing and if I could prove it to work with vagrant as a true PoC we can go ahead.  

I see in the debug output where the hiccup in the code is

Thanks.   



On Tuesday, 6 June 2017 17:02:40 UTC-5, Ian Koenig wrote:
There's been zero movement other than having someone assigned.  What can we do to have someone engage on this?  


On Monday, 5 June 2017 10:47:53 UTC-5, Ian Koenig wrote:
Thanks.  Ticket #3782 made on this.


On Monday, 5 June 2017 04:08:28 UTC-5, Alvaro Miranda Aguilera wrote:
Hello

Can you send an email to support @ <a href="http://hashicorp.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;">hashicorp.com ?

Thanks
alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/92eb0929-fb97-4d5c-9f20-17c9982ae1df%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

Ian Koenig
Thanks for helping on this Alvaro.



On Thursday, 8 June 2017 19:58:42 UTC-5, Ian Koenig wrote:
How can I get this moving Alvaro?   This is holding up a potentially decent sized order of vagrant-vmware-workstation plugin.   We can't use virtualbox in our environment due to other security software we utilize (it causes virtualbox to BSOD the windows systems) and the capabilities that vagrant offers is HUGE for what we are doing.   VMware Workstation doesn't trigger this BSOD in my testing and if I could prove it to work with vagrant as a true PoC we can go ahead.  

I see in the debug output where the hiccup in the code is

Thanks.   



On Tuesday, 6 June 2017 17:02:40 UTC-5, Ian Koenig wrote:
There's been zero movement other than having someone assigned.  What can we do to have someone engage on this?  


On Monday, 5 June 2017 10:47:53 UTC-5, Ian Koenig wrote:
Thanks.  Ticket #3782 made on this.


On Monday, 5 June 2017 04:08:28 UTC-5, Alvaro Miranda Aguilera wrote:
Hello

Can you send an email to support @ <a href="http://hashicorp.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;">hashicorp.com ?

Thanks
alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/ff8adc93-c2bc-432f-8b35-7e1211dda8c6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Vagrant 1.9.5 & VMware Workstation 12.5.6 - Networks not coming up

Chris Gannon
Hi Ian, 

What was the resolution to this issue? We're seeing a similar issue in our environment. 

Regards, 
Chris

On Wednesday, June 14, 2017 at 8:04:05 AM UTC+10, Ian Koenig wrote:
Thanks for helping on this Alvaro.



On Thursday, 8 June 2017 19:58:42 UTC-5, Ian Koenig wrote:
How can I get this moving Alvaro?   This is holding up a potentially decent sized order of vagrant-vmware-workstation plugin.   We can't use virtualbox in our environment due to other security software we utilize (it causes virtualbox to BSOD the windows systems) and the capabilities that vagrant offers is HUGE for what we are doing.   VMware Workstation doesn't trigger this BSOD in my testing and if I could prove it to work with vagrant as a true PoC we can go ahead.  

I see in the debug output where the hiccup in the code is

Thanks.   



On Tuesday, 6 June 2017 17:02:40 UTC-5, Ian Koenig wrote:
There's been zero movement other than having someone assigned.  What can we do to have someone engage on this?  


On Monday, 5 June 2017 10:47:53 UTC-5, Ian Koenig wrote:
Thanks.  Ticket #3782 made on this.


On Monday, 5 June 2017 04:08:28 UTC-5, Alvaro Miranda Aguilera wrote:
Hello

Can you send an email to support @ <a href="http://hashicorp.com" rel="nofollow" target="_blank" onmousedown="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;" onclick="this.href=&#39;http://www.google.com/url?q\x3dhttp%3A%2F%2Fhashicorp.com\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHjm5vN5i-39ddi68tHo8Rt3ZPfJQ&#39;;return true;">hashicorp.com ?

Thanks
alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/813a2162-00d6-46dd-a430-e308803828da%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.