Re: CentOS 6.2 network issues on Windows XP host

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: CentOS 6.2 network issues on Windows XP host

Mike Conigliaro
For what it's worth, I ran into this error when I had two VMs with the same IP address.

On Saturday, February 25, 2012 11:51:01 AM UTC-7, Richard van den Brand wrote:
Hi,

I hope somebody can help me out with this issue because it's really killing me and I'm running out of options...

Short introduction: We're using CentOS at the company I work for so I created a CentOS 6.2 base box. We also run a Puppet master, so the idea is to provision it with Puppet. During the "development" of the box on my Ubuntu machine all went fine. So yesterday I started testing my Vagrantfile and base box on other OS'es, since a lot of college's unfortunately are running Windows (7 and XP). On all Windows XP machines, there is *absolutely* no way to get host-only network mode to function (also tried bridged, same error) :(
On Windows 7, Ubuntu and OS X all works fine!

When I do "vagrant up" I always get the same error:

[default] Running any VM customizations...
[default] Booting VM...
[default] Waiting for VM to boot. This can take a few minutes.
[default] VM booted and ready for use!
[default] Configuring and enabling network interfaces...
The following SSH command responded with a non-zero exit status.
Vagrant assumes that this means the command failed!

/sbin/ifup eth1 2> /dev/null

When I log in on the box and try to manually ifup I get:

[root@localhost ~]# ifup eth1
 does not seem to be present, delaying initialization.

So I started my journey on Google searching for the error. I found a lot of people encountering the issue with cloning VM's so that makes sense. Also it is CentOS specific as far as I can see.
All the solutions lead to nothing, because as far as I can conclude all is fine. What I tried so far:

[root@localhost ~]# dmesg | grep eth
e1000 0000:00:03.0: eth0: (PCI:33MHz:32-bit) 08:00:27:f9:63:cd
e1000 0000:00:03.0: eth0: Intel(R) PRO/1000 Network Connection
e1000 0000:00:08.0: eth1: (PCI:33MHz:32-bit) 08:00:27:2a:4b:45
e1000 0000:00:08.0: eth1: Intel(R) PRO/1000 Network Connection
e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
eth0: no IPv6 routers present
e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
eth0: no IPv6 routers present

eth1 is there.

[root@localhost ~]# lspci
00:00.0 Host bridge: Intel Corporation 440FX - 82441FX PMC [Natoma] (rev 02)
00:01.0 ISA bridge: Intel Corporation 82371SB PIIX3 ISA [Natoma/Triton II]
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
00:02.0 VGA compatible controller: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter
00:03.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:04.0 System peripheral: InnoTek Systemberatung GmbH VirtualBox Guest Service
00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 08)
00:08.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
00:0d.0 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 02)

Also looks fine I guess?

[root@localhost ~]# ip -o link
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN \    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000\    link/ether 08:00:27:f9:63:cd brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000\    link/ether 08:00:27:2a:4b:45 brd ff:ff:ff:ff:ff:ff

I also tried to edit the /etc/sysconfig/network-scripts/ifcfg-eth1 file, by adding the correct HWADDR to it (that was missing) (yes I ignored the do not modify message :)):
#VAGRANT-BEGIN
# The contents below are automatically generated by Vagrant. Do not modify.
BOOTPROTO=static
IPADDR=33.33.33.10
NETMASK=255.255.255.0
HWADDR="08:00:27:2A:4B:45"
DEVICE=eth1
#VAGRANT-END

My Vagrantfile looks like this:
Vagrant::Config.run do |config|
  config.vm.box = "centos62"
  config.vm.box_url = "http://localhost/centos62.box"
  config.vm.boot_mode = :gui
  config.vm.network :hostonly, "33.33.33.10"
  config.ssh.max_tries = 50
  config.ssh.timeout   = 300
end

If needed I can send the URL for the box, but its just a fresh CentOS 6.2 netinstall with Puppet and Vagrant.
I am really curious why only on Windows XP it doesn't work... Is there any difference on VirtualBox networking support between different OS'es? Or is just a CentOS 6.2 issue?

Just for the record, when I do a test with the lucid32 base box from vagrantup.com with my Vagrantfile, all works fine.

Thanks in advance for your time!

Regards,
Richard


--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.