Port forwarding not working for Windows 7 host

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Port forwarding not working for Windows 7 host

Vaibhav Bhandari
I'm new to Vagrant and I have been trying to get a simple ruby app working on my setup following the instructions from:

I'm running Vagrant 1.2.4 on Virutalbox 4.2.16 with the guest OS as precise64 (Ubuntu) and host as Windows 7.

I have setup my app to do the following on the guest machine:
config.vm.network :forwarded_port, guest:3000, host: 3000 

I can successfully curl on the guest:
> curl http://localhost:3000
[success]

However I can't access the port from my host Windows machine.

Any thoughts what might be going on? I dont have any firewalls setup on the guest.

regards,
Vaibhav

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Port forwarding not working for Windows 7 host

Vaibhav Bhandari
Anyone else running in to this issue?

On Thursday, July 25, 2013 2:08:38 AM UTC-7, Vaibhav Bhandari wrote:
I'm new to Vagrant and I have been trying to get a simple ruby app working on my setup following the instructions from:

I'm running Vagrant 1.2.4 on Virutalbox 4.2.16 with the guest OS as precise64 (Ubuntu) and host as Windows 7.

I have setup my app to do the following on the guest machine:
config.vm.network :forwarded_port, guest:3000, host: 3000 

I can successfully curl on the guest:
[success]

However I can't access the port from my host Windows machine.

Any thoughts what might be going on? I dont have any firewalls setup on the guest.

regards,
Vaibhav

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Port forwarding not working for Windows 7 host

Vaibhav Bhandari
Seems like this works fine with a precise32 box. It still baffles me why precise64 fails.

On Saturday, July 27, 2013 11:41:17 PM UTC-7, Vaibhav Bhandari wrote:
Anyone else running in to this issue?

On Thursday, July 25, 2013 2:08:38 AM UTC-7, Vaibhav Bhandari wrote:
I'm new to Vagrant and I have been trying to get a simple ruby app working on my setup following the instructions from:

I'm running Vagrant 1.2.4 on Virutalbox 4.2.16 with the guest OS as precise64 (Ubuntu) and host as Windows 7.

I have setup my app to do the following on the guest machine:
config.vm.network :forwarded_port, guest:3000, host: 3000 

I can successfully curl on the guest:
[success]

However I can't access the port from my host Windows machine.

Any thoughts what might be going on? I dont have any firewalls setup on the guest.

regards,
Vaibhav

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.