Output: Error: The File is already in use

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Output: Error: The File is already in use

Curtis
Hi, I'm getting an error using vagrant 1.1.4 and vmware fusion.

$ vagrant up --provider=vmware_fusion
Bringing machine 'web' up with 'vmware_fusion' provider...
[web] Cloning Fusion VM: 'centos65fusion'. This can take some time...
[web] Verifying vmnet devices are healthy...
[web] Preparing network adapters...
[web] Starting the VMware VM...
An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:
 
Command: ["start", "/Users/curtis/working/vagrant/centos6fusion/.vagrant/machines/web/vmware_fusion/vm.vmwarevm/vagrant-centos-6.4-x86_64.vmx", "nogui", {:notify=>[:stdout, :stderr]}]
 
Output: Error: The file is already in use

==

Here's a gist with my vagrantfile: https://gist.github.com/curtisgithub/5248449

I'm guessing there's something wrong with the vagrant file? Anyone have any thoughts on that?

Thanks,
Curtis.

--
Twitter: @serverascode
Blog: serverascode.com

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Output: Error: The File is already in use

Mitchell Hashimoto
Curtis,

Could you get all the "*.log" files from ".vagrant/machines/web/vmware_fusion/vm.vmwarevm/" and gist them?

This is an issue with Fusion itself. Fusion is complaining that it can't open certain files for the VM because they are already in use.

Best,
Mitchell


On Tue, Mar 26, 2013 at 1:07 PM, Curtis <[hidden email]> wrote:
Hi, I'm getting an error using vagrant 1.1.4 and vmware fusion.


$ vagrant up --provider=vmware_fusion
Bringing machine 'web' up with 'vmware_fusion' provider...
[web] Cloning Fusion VM: 'centos65fusion'. This can take some time...
[web] Verifying vmnet devices are healthy...
[web] Preparing network adapters...
[web] Starting the VMware VM...
An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:
 
Command: ["start", "/Users/curtis/working/vagrant/centos6fusion/.vagrant/machines/web/vmware_fusion/vm.vmwarevm/vagrant-centos-6.4-x86_64.vmx", "nogui", {:notify=>[:stdout, :stderr]}]
 
Output: Error: The file is already in use

==

Here's a gist with my vagrantfile: https://gist.github.com/curtisgithub/5248449

I'm guessing there's something wrong with the vagrant file? Anyone have any thoughts on that?

Thanks,
Curtis.

--
Twitter: @serverascode
Blog: serverascode.com

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Output: Error: The File is already in use

Christopher Davis
In reply to this post by Curtis
Curtis,

I ran into this last night when creating a CentOS image. I was able to work around the problem by renaming the base image I used to create the box image.

cd ~/Documents/Virtual\ Machines.localized
mv vagrant-centos6-64.vmwarevm vagrant-centos6-64-base.vmwarevm

However, the problem would reoccur each time I tweaked my image. I suspect it has something to do with the image name defined within the plist or vmx file.

Chris
 

On Tuesday, March 26, 2013 4:07:49 PM UTC-4, Curtis wrote:
Hi, I'm getting an error using vagrant 1.1.4 and vmware fusion.

$ vagrant up --provider=vmware_fusion
Bringing machine 'web' up with 'vmware_fusion' provider...
[web] Cloning Fusion VM: 'centos65fusion'. This can take some time...
[web] Verifying vmnet devices are healthy...
[web] Preparing network adapters...
[web] Starting the VMware VM...
An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:
 
Command: ["start", "/Users/curtis/working/vagrant/centos6fusion/.vagrant/machines/web/vmware_fusion/vm.vmwarevm/vagrant-centos-6.4-x86_64.vmx", "nogui", {:notify=>[:stdout, :stderr]}]
 
Output: Error: The file is already in use

==

Here's a gist with my vagrantfile: https://gist.github.com/curtisgithub/5248449

I'm guessing there's something wrong with the vagrant file? Anyone have any thoughts on that?

Thanks,
Curtis.

--
Twitter: @serverascode
Blog: serverascode.com

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Output: Error: The File is already in use

Curtis
On Fri, Mar 29, 2013 at 9:54 AM, Christopher Davis <[hidden email]> wrote:
Curtis,

I ran into this last night when creating a CentOS image. I was able to work around the problem by renaming the base image I used to create the box image.

cd ~/Documents/Virtual\ Machines.localized
mv vagrant-centos6-64.vmwarevm vagrant-centos6-64-base.vmwarevm

However, the problem would reoccur each time I tweaked my image. I suspect it has something to do with the image name defined within the plist or vmx file.


Ok, thanks Chris. Good to know.

Curtis.
 
Chris
 

On Tuesday, March 26, 2013 4:07:49 PM UTC-4, Curtis wrote:
Hi, I'm getting an error using vagrant 1.1.4 and vmware fusion.

$ vagrant up --provider=vmware_fusion
Bringing machine 'web' up with 'vmware_fusion' provider...
[web] Cloning Fusion VM: 'centos65fusion'. This can take some time...
[web] Verifying vmnet devices are healthy...
[web] Preparing network adapters...
[web] Starting the VMware VM...
An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:
 
Command: ["start", "/Users/curtis/working/vagrant/centos6fusion/.vagrant/machines/web/vmware_fusion/vm.vmwarevm/vagrant-centos-6.4-x86_64.vmx", "nogui", {:notify=>[:stdout, :stderr]}]
 
Output: Error: The file is already in use

==

Here's a gist with my vagrantfile: https://gist.github.com/curtisgithub/5248449

I'm guessing there's something wrong with the vagrant file? Anyone have any thoughts on that?

Thanks,
Curtis.

--
Twitter: @serverascode
Blog: serverascode.com

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 



--
Twitter: @serverascode
Blog: serverascode.com

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Output: Error: The File is already in use

Mitchell Hashimoto
Curtis, Chris,

This is fixed with version 0.4.2 of the Fusion provider plugin, released today. Just `vagrant plugin install` the plugin again and it'll be fixed. :)

Best,
Mitchell


On Fri, Mar 29, 2013 at 6:24 PM, Curtis <[hidden email]> wrote:
On Fri, Mar 29, 2013 at 9:54 AM, Christopher Davis <[hidden email]> wrote:
Curtis,

I ran into this last night when creating a CentOS image. I was able to work around the problem by renaming the base image I used to create the box image.

cd ~/Documents/Virtual\ Machines.localized
mv vagrant-centos6-64.vmwarevm vagrant-centos6-64-base.vmwarevm

However, the problem would reoccur each time I tweaked my image. I suspect it has something to do with the image name defined within the plist or vmx file.


Ok, thanks Chris. Good to know.

Curtis.
 
Chris
 

On Tuesday, March 26, 2013 4:07:49 PM UTC-4, Curtis wrote:
Hi, I'm getting an error using vagrant 1.1.4 and vmware fusion.


$ vagrant up --provider=vmware_fusion
Bringing machine 'web' up with 'vmware_fusion' provider...
[web] Cloning Fusion VM: 'centos65fusion'. This can take some time...
[web] Verifying vmnet devices are healthy...
[web] Preparing network adapters...
[web] Starting the VMware VM...
An error occurred while executing `vmrun`, a utility for controlling
VMware machines. The command and output are below:
 
Command: ["start", "/Users/curtis/working/vagrant/centos6fusion/.vagrant/machines/web/vmware_fusion/vm.vmwarevm/vagrant-centos-6.4-x86_64.vmx", "nogui", {:notify=>[:stdout, :stderr]}]
 
Output: Error: The file is already in use

==

Here's a gist with my vagrantfile: https://gist.github.com/curtisgithub/5248449

I'm guessing there's something wrong with the vagrant file? Anyone have any thoughts on that?

Thanks,
Curtis.

--
Twitter: @serverascode
Blog: serverascode.com

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 



--
Twitter: @serverascode
Blog: serverascode.com

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.