No prompt in VM after Vagrant up - system just hangs

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

No prompt in VM after Vagrant up - system just hangs

Nigel
Hi all,

I'm running Vagrant 2.0.1 with VirtualBox 5.2.2 on a Windows 10 host, launching it from within Git Bash (part of Git for Windows 2.15.1.2) Previously, I had no problems spinning up the standard ubuntu/trusty64 image. Without knowingly making any changes, when I now run vagrant ssh, I connect to the VM, but it hangs without showing the command prompt.

I don't encounter this issue on my Linux host (Ubuntu 17.10 running the same versions of Vagrant and VirtualBox) with exactly the same Vagrant bootstrap provisioning files, so this looks like a Windows platform issue, but as I said, it's worked fine before.

I've tried re-installing both Vagrant and VirtualBox, clearing out old config files left behind by both apps (excluding removing the actual box images in the box folder) without success.

I would be very grateful for some advice, as I can't work in the Vagrant-managed VM anymore.

Many thanks.

Nigel

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: No prompt in VM after Vagrant up - system just hangs

Alvaro Miranda Aguilera
does this happen on a new box?

ie 

mkdir trusty64
cd trusty64
vagrant init -m ubuntu/trusty64
vagrant up

?

does happen with a different box? say hashicorp/precise64

Thanks
Alvaro

On Thu, Dec 7, 2017 at 1:02 PM, Nigel <[hidden email]> wrote:
Hi all,

I'm running Vagrant 2.0.1 with VirtualBox 5.2.2 on a Windows 10 host, launching it from within Git Bash (part of Git for Windows 2.15.1.2) Previously, I had no problems spinning up the standard ubuntu/trusty64 image. Without knowingly making any changes, when I now run vagrant ssh, I connect to the VM, but it hangs without showing the command prompt.

I don't encounter this issue on my Linux host (Ubuntu 17.10 running the same versions of Vagrant and VirtualBox) with exactly the same Vagrant bootstrap provisioning files, so this looks like a Windows platform issue, but as I said, it's worked fine before.

I've tried re-installing both Vagrant and VirtualBox, clearing out old config files left behind by both apps (excluding removing the actual box images in the box folder) without success.

I would be very grateful for some advice, as I can't work in the Vagrant-managed VM anymore.

Many thanks.

Nigel

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/CAHqq0ewhGuAkc%3DJzp3cEnXpk-m%3DVf4vOyPEyv1uwfrnxYOvb7w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: No prompt in VM after Vagrant up - system just hangs

Will Jaynes
I too have this same problem. Same Vagrant 2.0.1 with VirtualBox 5.2.2 on a Windows 10 host, launching it from within Git Bash. Both Laravel Homestead and  the hashicorp/precise64  act the same way. I also, previously had no problems, sorry I don't know what my previous setup was. When I run vagrant ssh I get onto the virtual machine in some kind of bash shell, but there's no prompt, no aliases (so the .bashrc hasn't been read), and the arrow keys and autocomplete doesn't work. It just strange. Not sure what to do.

On Friday, December 8, 2017 at 4:45:30 AM UTC-5, Alvaro Miranda Aguilera wrote:
does this happen on a new box?

ie 

mkdir trusty64
cd trusty64
vagrant init -m ubuntu/trusty64
vagrant up

?

does happen with a different box? say hashicorp/precise64

Thanks
Alvaro

On Thu, Dec 7, 2017 at 1:02 PM, Nigel <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="Gvf2VR-_CAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">n.bi...@...> wrote:
Hi all,

I'm running Vagrant 2.0.1 with VirtualBox 5.2.2 on a Windows 10 host, launching it from within Git Bash (part of Git for Windows 2.15.1.2) Previously, I had no problems spinning up the standard ubuntu/trusty64 image. Without knowingly making any changes, when I now run vagrant ssh, I connect to the VM, but it hangs without showing the command prompt.

I don't encounter this issue on my Linux host (Ubuntu 17.10 running the same versions of Vagrant and VirtualBox) with exactly the same Vagrant bootstrap provisioning files, so this looks like a Windows platform issue, but as I said, it's worked fine before.

I've tried re-installing both Vagrant and VirtualBox, clearing out old config files left behind by both apps (excluding removing the actual box images in the box folder) without success.

I would be very grateful for some advice, as I can't work in the Vagrant-managed VM anymore.

Many thanks.

Nigel

--
This mailing list is governed under the HashiCorp Community Guidelines - <a href="https://www.hashicorp.com/community-guidelines.html" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;">https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: <a href="https://github.com/mitchellh/vagrant/issues" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;">https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="Gvf2VR-_CAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">vagrant-up+...@googlegroups.com.
To view this discussion on the web visit <a href="https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;">https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;">https://groups.google.com/d/optout.



--
Alvaro

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/88301b79-aed3-4a8c-a400-92b9fc61ed20%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: No prompt in VM after Vagrant up - system just hangs

Robert Lilly
I too am experiencing this, same setup. I am suspecting something with the latest version of Git for Windows. When I use cmd.exe to do 'vagrant up' and then 'vagrant ssh' I get the normal BASH prompt and things look as expected. But when I use Git Bash, after doing 'vagrant ssh' things get wonky. Also, if I launch the VirtualBox GUI and access the VM that way I get a normal BASH prompt.

I will try rolling back to an earlier version of Git for Windows and see how that works. I will report my findings back here.

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.

GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/eb1f9de6-e247-48a0-8b7e-406da80e5ea6%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: No prompt in VM after Vagrant up - system just hangs

thornlord
Hi all,

I was able to use the `ssh` command from my $PATH as follows.

ssh vagrant@127.0.0.1 -p2222 -i C:/users/sdalziel/learn-chef/.vagrant/machines/default/virtualbox/private_key

I feel that this is only a work-around and hope to either post or see the steps to repair soon.

Cheers.
S

On Sunday, 17 December 2017 12:57:34 UTC-5, Robert Lilly wrote:
I too am experiencing this, same setup. I am suspecting something with the latest version of Git for Windows. When I use cmd.exe to do 'vagrant up' and then 'vagrant ssh' I get the normal BASH prompt and things look as expected. But when I use Git Bash, after doing 'vagrant ssh' things get wonky. Also, if I launch the VirtualBox GUI and access the VM that way I get a normal BASH prompt.

I will try rolling back to an earlier version of Git for Windows and see how that works. I will report my findings back here.

--
This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
 
GitHub Issues: https://github.com/mitchellh/vagrant/issues
IRC: #vagrant on Freenode
---
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/943507be-1b91-4ab9-8d24-39b72e85ac39%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: No prompt in VM after Vagrant up - system just hangs

Tara Walker
In reply to this post by Alvaro Miranda Aguilera
I found this solution and it works perfectly with vagrant ssh
Environment: 
Vagrant version : 2.0.1
  • Windows 10
  • Virtualbox : 5.1.30
  • git bash : 2.15.1
  • Solved using this by putting this line in .bash_profile in c:/users/<yourlogin>
    VAGRANT_PREFER_SYSTEM_BIN=1 vagrant ssh

    Reference can be found here: https://github.com/hashicorp/vagrant/issues/9143

    On Friday, December 8, 2017 at 4:45:30 AM UTC-5, Alvaro Miranda Aguilera wrote:

    does this happen on a new box?

    ie 

    mkdir trusty64
    cd trusty64
    vagrant init -m ubuntu/trusty64
    vagrant up

    ?

    does happen with a different box? say hashicorp/precise64

    Thanks
    Alvaro

    On Thu, Dec 7, 2017 at 1:02 PM, Nigel <<a onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;" href="javascript:" target="_blank" rel="nofollow" gdf-obfuscated-mailto="Gvf2VR-_CAAJ">n.bi...@...> wrote:
    Hi all,

    I'm running Vagrant 2.0.1 with VirtualBox 5.2.2 on a Windows 10 host, launching it from within Git Bash (part of Git for Windows 2.15.1.2) Previously, I had no problems spinning up the standard ubuntu/trusty64 image. Without knowingly making any changes, when I now run vagrant ssh, I connect to the VM, but it hangs without showing the command prompt.

    I don't encounter this issue on my Linux host (Ubuntu 17.10 running the same versions of Vagrant and VirtualBox) with exactly the same Vagrant bootstrap provisioning files, so this looks like a Windows platform issue, but as I said, it's worked fine before.

    I've tried re-installing both Vagrant and VirtualBox, clearing out old config files left behind by both apps (excluding removing the actual box images in the box folder) without success.

    I would be very grateful for some advice, as I can't work in the Vagrant-managed VM anymore.

    Many thanks.

    Nigel

    --
    This mailing list is governed under the HashiCorp Community Guidelines - <a onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fwww.hashicorp.com%2Fcommunity-guidelines.html\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNGHa_CaKfZaJiwbkUndUQbVGlQCDw&#39;;return true;" href="https://www.hashicorp.com/community-guidelines.html" target="_blank" rel="nofollow">https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
     
    GitHub Issues: <a onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Fgithub.com%2Fmitchellh%2Fvagrant%2Fissues\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHxcA5DuHlQlPInMi_k1Pz4pMNqNw&#39;;return true;" href="https://github.com/mitchellh/vagrant/issues" target="_blank" rel="nofollow">https://github.com/mitchellh/vagrant/issues
    IRC: #vagrant on Freenode
    ---
    You received this message because you are subscribed to the Google Groups "Vagrant" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to <a onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;" href="javascript:" target="_blank" rel="nofollow" gdf-obfuscated-mailto="Gvf2VR-_CAAJ">vagrant-up+...@googlegroups.com.
    To view this discussion on the web visit <a onmousedown="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com?utm_medium\x3demail\x26utm_source\x3dfooter&#39;;return true;" href="https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com?utm_medium=email&amp;utm_source=footer" target="_blank" rel="nofollow">https://groups.google.com/d/msgid/vagrant-up/c8c54605-241e-4d98-b430-644447837da4%40googlegroups.com.
    For more options, visit <a onmousedown="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" onclick="this.href=&#39;https://groups.google.com/d/optout&#39;;return true;" href="https://groups.google.com/d/optout" target="_blank" rel="nofollow">https://groups.google.com/d/optout.



    --
    Alvaro

    --
    This mailing list is governed under the HashiCorp Community Guidelines - https://www.hashicorp.com/community-guidelines.html. Behavior in violation of those guidelines may result in your removal from this mailing list.
     
    GitHub Issues: https://github.com/mitchellh/vagrant/issues
    IRC: #vagrant on Freenode
    ---
    You received this message because you are subscribed to the Google Groups "Vagrant" group.
    To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
    To view this discussion on the web visit https://groups.google.com/d/msgid/vagrant-up/7609eb6c-33c9-4506-81c8-92d891531902%40googlegroups.com.
    For more options, visit https://groups.google.com/d/optout.