Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

classic Classic list List threaded Threaded
7 messages Options
Rav
Reply | Threaded
Open this post in threaded view
|

Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

Rav
Hey all,

I am playing around with Vagrant and using VirtualBox.

I am trying to follow the "getting started" section on the Vagrant Online Docs http://docs.vagrantup.com/v2/getting-started/index.html

On running the below: 

$ vagrant init precise32 http://files.vagrantup.com/precise32.box
$ vagrant up

I get the following:

INFO interface: error: There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

Any ideas? I have a feeling that this is actually a problem with VirtualBox as I have tried this on Win7 x64 and Win8 x64 machines.

I am not able to import an appliance through the VirtualBox UI either :(

I have brought the O'Reilly book on Vagrant which uses VirtualBox in all its examples so want to get this working if possible.

Thanks!

asa

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

Zippy K
Hi, I've been struggling around with the same problem, trying one thing after another (switching between precice32 and precice64 boxes, de-installing Varant and Virtuabox and changing install order). No luck. Not even by making sure I've deleted the Vagrantfile file and the %USERPROFILE%\.vagrant.d directory tree.

Now I downloaded an older version of VirtualBox (two versions back, insall file VirtualBox-4.2.8-83876-Win.exe instead of the current VirtualBox-4.2.14-86644-Win.exe) and now thing look brighter, i.e., as expected:

>vagrant init precise32 http://files.vagrantup.com/precise32.box
A `Vagrantfile` has been placed in this directory. You are now
ready to `vagrant up` your first virtual environment! Please read
the comments in the Vagrantfile as well as documentation on
`vagrantup.com` for more information on using Vagrant.

AND

>vagrant up
Bringing machine 'default' up with 'virtualbox' provider...
[default] Box 'precise32' was not found. Fetching box from specified URL for
the provider 'virtualbox'. Note that if the URL does not have
a box for this provider, you should interrupt Vagrant now and add
the box yourself. Otherwise Vagrant will attempt to download the
full box prior to discovering this error.
Downloading or copying the box...
←[0KExtracting box...ate: 1191k/s, Estimated time remaining: --:--:--)
Successfully added box 'precise32' with provider 'virtualbox'!
[default] Importing base box 'precise32'...
←[0K[default] Matching MAC address for NAT networking...
[default] Setting the name of the VM...
[default] Clearing any previously set forwarded ports...
[default] Creating shared folders metadata...
[default] Clearing any previously set network interfaces...
[default] Preparing network interfaces based on configuration...
[default] Forwarding ports...
[default] -- 22 => 2222 (adapter 1)
[default] Booting VM...
[default] Waiting for VM to boot. This can take a few minutes.
[default] VM booted and ready for use!
[default] Configuring and enabling network interfaces...
[default] Mounting shared folders...
[default] -- /vagrant


Being a Vagrant newbie myself, I'm not sure, but doesn't this look like something in VirtualBox changed so the Vagrant/VirtualBox interaction also broke?
Just to be clear, this is on Windows 7 (32 bit) on 64 bit hardware.



On Saturday, June 22, 2013 4:58:31 PM UTC+2, Rav wrote:
Hey all,

I am playing around with Vagrant and using VirtualBox.

I am trying to follow the "getting started" section on the Vagrant Online Docs http://docs.vagrantup.com/v2/getting-started/index.html

On running the below: 

$ vagrant up

I get the following:

INFO interface: error: There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

Any ideas? I have a feeling that this is actually a problem with VirtualBox as I have tried this on Win7 x64 and Win8 x64 machines.

I am not able to import an appliance through the VirtualBox UI either :(

I have brought the O'Reilly book on Vagrant which uses VirtualBox in all its examples so want to get this working if possible.

Thanks!

asa

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

Mitchell Hashimoto-2
In reply to this post by Rav
It turns out the fix for this is to downgrade to VirtualBox 4.2.12. (Fixed via a convo on Twitter)

On Saturday, June 22, 2013 7:58:31 AM UTC-7, Rav wrote:
Hey all,

I am playing around with Vagrant and using VirtualBox.

I am trying to follow the "getting started" section on the Vagrant Online Docs http://docs.vagrantup.com/v2/getting-started/index.html

On running the below: 

$ vagrant up

I get the following:

INFO interface: error: There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

Any ideas? I have a feeling that this is actually a problem with VirtualBox as I have tried this on Win7 x64 and Win8 x64 machines.

I am not able to import an appliance through the VirtualBox UI either :(

I have brought the O'Reilly book on Vagrant which uses VirtualBox in all its examples so want to get this working if possible.

Thanks!

asa

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Rav
Reply | Threaded
Open this post in threaded view
|

Re: Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

Rav


On Sunday, June 23, 2013 10:02:02 PM UTC+1, Mitchell Hashimoto wrote:
It turns out the fix for this is to downgrade to VirtualBox 4.2.12. (Fixed via a convo on Twitter)

On Saturday, June 22, 2013 7:58:31 AM UTC-7, Rav wrote:
Hey all,

I am playing around with Vagrant and using VirtualBox.

I am trying to follow the "getting started" section on the Vagrant Online Docs http://docs.vagrantup.com/v2/getting-started/index.html

On running the below: 

$ vagrant up

I get the following:

INFO interface: error: There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

Any ideas? I have a feeling that this is actually a problem with VirtualBox as I have tried this on Win7 x64 and Win8 x64 machines.

I am not able to import an appliance through the VirtualBox UI either :(

I have brought the O'Reilly book on Vagrant which uses VirtualBox in all its examples so want to get this working if possible.

Thanks!

asa

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Rav
Reply | Threaded
Open this post in threaded view
|

Re: Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

Rav
In reply to this post by Rav
I tweeted my issue and Mitchell responded :) I downloaded to v4.2.12 which I had to search for and hey presto it worked.



On Saturday, June 22, 2013 3:58:31 PM UTC+1, Rav wrote:
Hey all,

I am playing around with Vagrant and using VirtualBox.

I am trying to follow the "getting started" section on the Vagrant Online Docs http://docs.vagrantup.com/v2/getting-started/index.html

On running the below: 

$ vagrant up

I get the following:

INFO interface: error: There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

Any ideas? I have a feeling that this is actually a problem with VirtualBox as I have tried this on Win7 x64 and Win8 x64 machines.

I am not able to import an appliance through the VirtualBox UI either :(

I have brought the O'Reilly book on Vagrant which uses VirtualBox in all its examples so want to get this working if possible.

Thanks!

asa

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

Kirk Kohler
I'm having a similar issue and installing VirtualBox 4.2.12 does get ride of the vagrant up issue above.  However, I only ran into this issue because I was having issues with VirtualBox 4.2.16 which made me decide to try something older, v. 4.2.8.  Installing back to 4.2.12 gives me the same error I saw with 4.2.16.  I'm stuck in this circular loop. 

I cannot see my syncronized files within vagrant.  Also, creating files within the vagrant shell doesn't appear on my local machine. 

I do see in the VirtualBox Gui, that the folders are shared as expected. 

Any ideas?

I"m running win8 64-bit with VirtualBox 4.2.12 (4.2.12 extensions) & Vagrant 1.2.4

Thanks,
Kirk


On Sunday, June 23, 2013 2:05:49 PM UTC-7, Rav wrote:
I tweeted my issue and Mitchell responded :) I downloaded to v4.2.12 which I had to search for and hey presto it worked.



On Saturday, June 22, 2013 3:58:31 PM UTC+1, Rav wrote:
Hey all,

I am playing around with Vagrant and using VirtualBox.

I am trying to follow the "getting started" section on the Vagrant Online Docs http://docs.vagrantup.com/v2/getting-started/index.html

On running the below: 

$ vagrant up

I get the following:

INFO interface: error: There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

Any ideas? I have a feeling that this is actually a problem with VirtualBox as I have tried this on Win7 x64 and Win8 x64 machines.

I am not able to import an appliance through the VirtualBox UI either :(

I have brought the O'Reilly book on Vagrant which uses VirtualBox in all its examples so want to get this working if possible.

Thanks!

asa

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: Newbie help (Vagrant 1.2.2 with VirtualBox 4.2.14 running on a Windows 7/8 x64)

Kirk Kohler
In reply to this post by Rav
I'm having a similar issue and installing VirtualBox 4.2.12 does get ride of the vagrant up issue above.  However, I only ran into this issue because I was having issues with VirtualBox 4.2.16 which made me decide to try something older, v. 4.2.8.  Installing back to 4.2.12 gives me the same error I saw with 4.2.16.  I'm stuck in this circular loop. 

I cannot see my synchronized files within vagrant.  Also, creating files within the vagrant shell doesn't appear on my local machine. 

I do see in the VirtualBox Gui, that the folders are shared as expected. 

Any ideas?

I"m running win8 64-bit with VirtualBox 4.2.12 (4.2.12 extensions) & Vagrant 1.2.4

Thanks,
Kirk

On Sunday, June 23, 2013 2:05:49 PM UTC-7, Rav wrote:
I tweeted my issue and Mitchell responded :) I downloaded to v4.2.12 which I had to search for and hey presto it worked.



On Saturday, June 22, 2013 3:58:31 PM UTC+1, Rav wrote:
Hey all,

I am playing around with Vagrant and using VirtualBox.

I am trying to follow the "getting started" section on the Vagrant Online Docs http://docs.vagrantup.com/v2/getting-started/index.html

On running the below: 

$ vagrant up

I get the following:

INFO interface: error: There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["import", "C:/Users/Ravi/.vagrant.d/boxes/precise32/virtualbox/box.ovf"]

Stderr: 0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting C:\Users\Ravi\.vagrant.d\boxes\precise32\virtualbox\box.ovf...
OK.
0%...
Progress object failure: RPC_S_SERVER_UNAVAILABLE 0x800706BA

Any ideas? I have a feeling that this is actually a problem with VirtualBox as I have tried this on Win7 x64 and Win8 x64 machines.

I am not able to import an appliance through the VirtualBox UI either :(

I have brought the O'Reilly book on Vagrant which uses VirtualBox in all its examples so want to get this working if possible.

Thanks!

asa

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.