New provider plugin: vagrant-softlayer

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

New provider plugin: vagrant-softlayer

Emyl
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:

https://github.com/audiolize/vagrant-softlayer

Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Julio Lajara
Hi Emyl, im looking forward to using this plugin in prod environment, was wondering if you could add an enhancement to be able to specify the blockDevices option to the createObject template. Ive opened a ticket for it on the github project.

Thanks,

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:

<a href="https://github.com/audiolize/vagrant-softlayer" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;">https://github.com/audiolize/vagrant-softlayer

Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Julio Lajara
In reply to this post by Emyl
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:

<a href="https://github.com/audiolize/vagrant-softlayer" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;">https://github.com/audiolize/vagrant-softlayer

Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Paul O'Flynn
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.




On Thursday, February 27, 2014 10:05:37 AM UTC-8, Julio Lajara wrote:
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:

<a href="https://github.com/audiolize/vagrant-softlayer" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;">https://github.com/audiolize/vagrant-softlayer

Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Torben Knerr
Hi Paul,

you can run `VAGRANT_LOG=DEBUG vagrant plugin install vagrant-softlayer` to get more information on what's going wrong.

I suspect you might need to have the Ruby DevKit installed for compiling the json gem:

HTH,
Torben 




On Tue, Jul 1, 2014 at 7:20 AM, Paul O'Flynn <[hidden email]> wrote:
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.




On Thursday, February 27, 2014 10:05:37 AM UTC-8, Julio Lajara wrote:
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:


Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Alvaro Miranda Aguilera
In reply to this post by Paul O'Flynn
general vagrant questions here is fine..

for that specific plugin, here is fine, as long someone reply

for that particular plugin, this is a good start for issues




On Tue, Jul 1, 2014 at 5:20 PM, Paul O'Flynn <[hidden email]> wrote:
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.




On Thursday, February 27, 2014 10:05:37 AM UTC-8, Julio Lajara wrote:
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:


Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Paul O'Flynn
In reply to this post by Torben Knerr
Hi Folks,

Thanks for the prompt replies! The debug log definitely shows some extra information as below. This in turn looks remarkably like this issue https://github.com/mitchellh/vagrant/issues/3764 I get this 100% consistently BTW; I've only tried it from within my office although I can't imagine there's a network issue here... Now I'm wondering which repo's issues should I be adding to?

Paul




 INFO cli: CLI: [] "plugin" ["install", "vagrant-softlayer"]
DEBUG cli: Invoking command class: VagrantPlugins::CommandPlugin::Command::Root ["install", "vagrant-softlayer"]
DEBUG root: Invoking command class: VagrantPlugins::CommandPlugin::Command::Install ["vagrant-softlayer"]
 INFO loader: Loading configuration in order: [:home, :root]
DEBUG loader: Configuration loaded successfully, finalizing and returning
 INFO host: Autodetecting host type for [#<Vagrant::Environment: C:/repos/vagrant2>]
DEBUG host: Trying: arch
DEBUG host: Trying: darwin
DEBUG host: Trying: freebsd
DEBUG host: Trying: gentoo
DEBUG host: Trying: opensuse
DEBUG host: Trying: redhat
DEBUG host: Trying: slackware
DEBUG host: Trying: bsd
DEBUG host: Trying: linux
DEBUG host: Trying: null
DEBUG host: Trying: windows
 INFO host: Detected: windows!
 INFO runner: Preparing hooks for middleware sequence...
 INFO runner: 1 hooks defined.
 INFO runner: Running action: #<Vagrant::Action::Builder:0x39fb790>
 INFO warden: Calling IN action: #<VagrantPlugins::CommandPlugin::Action::InstallGem:0x379b168>
 INFO interface: info: Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
ERROR warden: Error occurred: Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

Net::HTTPNotFound: No gems found matching "vagrant-share" "0.9.6" nil
 INFO warden: Beginning recovery process...
 INFO warden: Calling recover: #<VagrantPlugins::CommandPlugin::Action::InstallGem:0x379b168>
 INFO warden: Recovery complete.
 INFO environment: Running hook: environment_unload
 INFO runner: Preparing hooks for middleware sequence...
 INFO runner: 1 hooks defined.
 INFO runner: Running action: #<Vagrant::Action::Builder:0x41db4f0>
ERROR vagrant: Vagrant experienced an error! Details:
ERROR vagrant: #<Vagrant::Errors::BundlerError: Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

Net::HTTPNotFound: No gems found matching "vagrant-share" "0.9.6" nil>
ERROR vagrant: Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

Net::HTTPNotFound: No gems found matching "vagrant-share" "0.9.6" nil
ERROR vagrant: C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/plugin/manager.rb:87:in `rescue in install_plugin'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/plugin/manager.rb:44:in `install_plugin'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/plugins/commands/plugin/action/install_gem.rb:28:in `call'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/action/warden.rb:34:in `call'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/action/builder.rb:116:in `call'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/action/runner.rb:66:in `block in run'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/util/busy.rb:19:in `busy'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/action/runner.rb:66:in `run'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/plugins/commands/plugin/command/base.rb:14:in `action'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/plugins/commands/plugin/command/install.rb:32:in `block in execute'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/plugins/commands/plugin/command/install.rb:31:in `each'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/plugins/commands/plugin/command/install.rb:31:in `execute'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/plugins/commands/plugin/command/root.rb:56:in `execute'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/cli.rb:42:in `execute'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/lib/vagrant/environment.rb:252:in `cli'
C:/HashiCorp/Vagrant/embedded/gems/gems/vagrant-1.6.3/bin/vagrant:166:in `<main>'
 INFO interface: error: Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

Net::HTTPNotFound: No gems found matching "vagrant-share" "0.9.6" nil
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

Net::HTTPNotFound: No gems found matching "vagrant-share" "0.9.6" nil
 INFO interface: Machine: error-exit ["Vagrant::Errors::BundlerError", "Bundler, the underlying system Vagrant uses to install plugins,\nreported an error. The error is shown below. These errors are usually\ncaused by misconfigured plugin installations or transient network\nissues. The error from Bundler is:\n\nNet::HTTPNotFound: No gems found matching \"vagrant-share\" \"0.9.6\" nil"]


On Monday, June 30, 2014 11:52:54 PM UTC-7, Torben Knerr wrote:
Hi Paul,

you can run `VAGRANT_LOG=DEBUG vagrant plugin install vagrant-softlayer` to get more information on what's going wrong.

I suspect you might need to have the Ruby DevKit installed for compiling the json gem:
<a href="http://rubyinstaller.org/add-ons/devkit/" target="_blank" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;">http://rubyinstaller.org/add-ons/devkit/

HTH,
Torben 




On Tue, Jul 1, 2014 at 7:20 AM, Paul O'Flynn <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="kz6WPs5zHHsJ" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">pof...@...> wrote:
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.



--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Paul O'Flynn
In reply to this post by Torben Knerr
P.S. I did install the DevKit and add it to my path before I ran the plugin install attempt below, thx.

On Monday, June 30, 2014 11:52:54 PM UTC-7, Torben Knerr wrote:
Hi Paul,

you can run `VAGRANT_LOG=DEBUG vagrant plugin install vagrant-softlayer` to get more information on what's going wrong.

I suspect you might need to have the Ruby DevKit installed for compiling the json gem:
<a href="http://rubyinstaller.org/add-ons/devkit/" target="_blank" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;">http://rubyinstaller.org/add-ons/devkit/

HTH,
Torben 




On Tue, Jul 1, 2014 at 7:20 AM, Paul O'Flynn <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="kz6WPs5zHHsJ" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">pof...@...> wrote:
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.




On Thursday, February 27, 2014 10:05:37 AM UTC-8, Julio Lajara wrote:
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:

<a href="https://github.com/audiolize/vagrant-softlayer" target="_blank" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;">https://github.com/audiolize/vagrant-softlayer

Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="kz6WPs5zHHsJ" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">vagrant-up+...@googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" onmousedown="this.href='https://groups.google.com/d/optout';return true;" onclick="this.href='https://groups.google.com/d/optout';return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Paul O'Flynn
Ok I have verified that this is a Windows-only issue and have logged an issue on the GitHub repo of the plugin, thanks. 


On Tue, Jul 1, 2014 at 8:59 AM, Paul O'Flynn <[hidden email]> wrote:
P.S. I did install the DevKit and add it to my path before I ran the plugin install attempt below, thx.


On Monday, June 30, 2014 11:52:54 PM UTC-7, Torben Knerr wrote:
Hi Paul,

you can run `VAGRANT_LOG=DEBUG vagrant plugin install vagrant-softlayer` to get more information on what's going wrong.

I suspect you might need to have the Ruby DevKit installed for compiling the json gem:

HTH,
Torben 




On Tue, Jul 1, 2014 at 7:20 AM, Paul O'Flynn <[hidden email]> wrote:
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.




On Thursday, February 27, 2014 10:05:37 AM UTC-8, Julio Lajara wrote:
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:


Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to vagrant-up+...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "Vagrant" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.



--

Paul


--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Matt-2

Hi Everyone,

Sorry if this question is very basic, I am new to Vagrant:

I am getting a weird error with the vagrant-softlayer plugin and I wanted to see if anyone could point me in the right direction.

I am doing this simple vagrant box add command and keep getting the following error: "translation missing: en.vagrant_softlayer.errors.api_error". I am not sure what this error message is saying. I have tried this and gotten the same result on cygwin and centos. Meanwhile, my curl access to the softlayer REST client is working.

Please let me know if you have any thoughts on what might be going wrong here.

All the best,

Matt



On Tuesday, July 1, 2014 at 8:27:38 PM UTC-4, Paul O'Flynn wrote:
Ok I have verified that this is a Windows-only issue and have logged <a href="https://github.com/audiolize/vagrant-softlayer/issues/10" target="_blank" rel="nofollow" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer%2Fissues%2F10\46sa\75D\46sntz\0751\46usg\75AFQjCNE3KeiGMk-mjs_xyrD5KHAeq0lS3A';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer%2Fissues%2F10\46sa\75D\46sntz\0751\46usg\75AFQjCNE3KeiGMk-mjs_xyrD5KHAeq0lS3A';return true;">an issue on the GitHub repo of the plugin, thanks. 


On Tue, Jul 1, 2014 at 8:59 AM, Paul O'Flynn <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="-5EAx08oN9MJ" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">pof...@...> wrote:
P.S. I did install the DevKit and add it to my path before I ran the plugin install attempt below, thx.


On Monday, June 30, 2014 11:52:54 PM UTC-7, Torben Knerr wrote:
Hi Paul,

you can run `VAGRANT_LOG=DEBUG vagrant plugin install vagrant-softlayer` to get more information on what's going wrong.

I suspect you might need to have the Ruby DevKit installed for compiling the json gem:
<a href="http://rubyinstaller.org/add-ons/devkit/" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;">http://rubyinstaller.org/add-ons/devkit/

HTH,
Torben 




On Tue, Jul 1, 2014 at 7:20 AM, Paul O'Flynn <[hidden email]> wrote:
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.




On Thursday, February 27, 2014 10:05:37 AM UTC-8, Julio Lajara wrote:
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:

<a href="https://github.com/audiolize/vagrant-softlayer" target="_blank" rel="nofollow" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;">https://github.com/audiolize/vagrant-softlayer

Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to vagrant-up+...@googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/optout';return true;" onclick="this.href='https://groups.google.com/d/optout';return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "Vagrant" group.
To unsubscribe from this topic, visit <a href="https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe';return true;" onclick="this.href='https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe';return true;">https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe.
To unsubscribe from this group and all its topics, send an email to <a href="javascript:" target="_blank" gdf-obfuscated-mailto="-5EAx08oN9MJ" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">vagrant-up+...@googlegroups.com.
For more options, visit <a href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/optout';return true;" onclick="this.href='https://groups.google.com/d/optout';return true;">https://groups.google.com/d/optout.



--

Paul


--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: New provider plugin: vagrant-softlayer

Julio Lajara
What version of the plugin are you using? Feel free to open a ticket on github with the vagrant debug output and we can work through it.

Thanks,
On 01/27/2015 10:54 AM, Matt wrote:

Hi Everyone,

Sorry if this question is very basic, I am new to Vagrant:

I am getting a weird error with the vagrant-softlayer plugin and I wanted to see if anyone could point me in the right direction.

I am doing this simple vagrant box add command and keep getting the following error: "translation missing: en.vagrant_softlayer.errors.api_error". I am not sure what this error message is saying. I have tried this and gotten the same result on cygwin and centos. Meanwhile, my curl access to the softlayer REST client is working.

Please let me know if you have any thoughts on what might be going wrong here.

All the best,

Matt



On Tuesday, July 1, 2014 at 8:27:38 PM UTC-4, Paul O'Flynn wrote:
Ok I have verified that this is a Windows-only issue and have logged <a moz-do-not-send="true" href="https://github.com/audiolize/vagrant-softlayer/issues/10" target="_blank" rel="nofollow" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer%2Fissues%2F10\46sa\75D\46sntz\0751\46usg\75AFQjCNE3KeiGMk-mjs_xyrD5KHAeq0lS3A';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer%2Fissues%2F10\46sa\75D\46sntz\0751\46usg\75AFQjCNE3KeiGMk-mjs_xyrD5KHAeq0lS3A';return true;">an issue on the GitHub repo of the plugin, thanks. 


On Tue, Jul 1, 2014 at 8:59 AM, Paul O'Flynn <<a moz-do-not-send="true" href="javascript:" target="_blank" gdf-obfuscated-mailto="-5EAx08oN9MJ" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">pof...@...> wrote:
P.S. I did install the DevKit and add it to my path before I ran the plugin install attempt below, thx.


On Monday, June 30, 2014 11:52:54 PM UTC-7, Torben Knerr wrote:
Hi Paul,

you can run `VAGRANT_LOG=DEBUG vagrant plugin install vagrant-softlayer` to get more information on what's going wrong.

I suspect you might need to have the Ruby DevKit installed for compiling the json gem:
<a moz-do-not-send="true" href="http://rubyinstaller.org/add-ons/devkit/" target="_blank" rel="nofollow" onmousedown="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;" onclick="this.href='http://www.google.com/url?q\75http%3A%2F%2Frubyinstaller.org%2Fadd-ons%2Fdevkit%2F\46sa\75D\46sntz\0751\46usg\75AFQjCNEcFJx3Fgp7jn5zK_f_-BFRvDhcKQ';return true;">http://rubyinstaller.org/add-ons/devkit/

HTH,
Torben 




On Tue, Jul 1, 2014 at 7:20 AM, Paul O'Flynn <[hidden email]> wrote:
I'd love to use this plugin but I can't install it :-( I am on Win 7, Cygwin, vagrant 1.6.3 (got the same error with 1.5.1). 

Also, while I'm here, where is the best place to get support/ask questions?

Thanks in advance,

Paul



$ vagrant plugin install vagrant-softlayer
Installing the 'vagrant-softlayer' plugin. This can take a few minutes...
Bundler, the underlying system Vagrant uses to install plugins,
reported an error. The error is shown below. These errors are usually
caused by misconfigured plugin installations or transient network
issues. The error from Bundler is:

An error occurred while installing json (1.8.1), and Bundler cannot continue.
Make sure that `gem install json -v '1.8.1'` succeeds before bundling.




On Thursday, February 27, 2014 10:05:37 AM UTC-8, Julio Lajara wrote:
Hi Emyl, have you ever experienced transaction hangs while using the plugin?

Ive made some additions to the plugin that I wanted to test so I uninstalled the current 0.2 and went into my git repo and ran the normal vagrant plugin install but for some reason the changes I added arent reflected in the plugin installed by vagrant. Any idea why that is? Im not fully familiar with how ruby works yet so im kind of stumped.

On Monday, November 18, 2013 9:06:38 AM UTC-5, Emyl wrote:
Hi all,

I'm very excited in announcing a new provider plugin for managing SoftLayer Cloud Computing instances!

For anyone interested, here is the project page:

<a moz-do-not-send="true" href="https://github.com/audiolize/vagrant-softlayer" target="_blank" rel="nofollow" onmousedown="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;" onclick="this.href='https://www.google.com/url?q\75https%3A%2F%2Fgithub.com%2Faudiolize%2Fvagrant-softlayer\46sa\75D\46sntz\0751\46usg\75AFQjCNHG8joIuvyey3uKxTHSsIyz5_ptFQ';return true;">https://github.com/audiolize/vagrant-softlayer

Any comment/advice/feedback would be greatly appreciated!

Cheers,
Emyl
--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to vagrant-up+...@googlegroups.com.
For more options, visit <a moz-do-not-send="true" href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/optout';return true;" onclick="this.href='https://groups.google.com/d/optout';return true;">https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the Google Groups "Vagrant" group.
To unsubscribe from this topic, visit <a moz-do-not-send="true" href="https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe';return true;" onclick="this.href='https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe';return true;">https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe.
To unsubscribe from this group and all its topics, send an email to <a moz-do-not-send="true" href="javascript:" target="_blank" gdf-obfuscated-mailto="-5EAx08oN9MJ" rel="nofollow" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">vagrant-up+...@googlegroups.com.
For more options, visit <a moz-do-not-send="true" href="https://groups.google.com/d/optout" target="_blank" rel="nofollow" onmousedown="this.href='https://groups.google.com/d/optout';return true;" onclick="this.href='https://groups.google.com/d/optout';return true;">https://groups.google.com/d/optout.



--

Paul


--
You received this message because you are subscribed to a topic in the Google Groups "Vagrant" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/vagrant-up/4NCPswy106s/unsubscribe.
To unsubscribe from this group and all its topics, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.