How to install gems + vagrant 1.1 ?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

How to install gems + vagrant 1.1 ?

David Cournapeau
Hi there,

My understanding is that from vagrant 1.1, we can only install it from the installer (or from sources).

Because I am using vagrant to run windows guests as well, I need the windows plugin. With vagrant < 1.1, I could simply install the corresponding plugin, but I don't know how to deal with it now ?

I think there should be some documentations on the new doc website to indicate how to do this,

cheers,
David

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: How to install gems + vagrant 1.1 ?

Mitchell Hashimoto
David,


The windows plugin needs to be updated to be 1.1 compatible then you can do that.

Best,
Mitchell


On Mon, Mar 25, 2013 at 3:17 AM, David Cournapeau <[hidden email]> wrote:
Hi there,

My understanding is that from vagrant 1.1, we can only install it from the installer (or from sources).

Because I am using vagrant to run windows guests as well, I need the windows plugin. With vagrant < 1.1, I could simply install the corresponding plugin, but I don't know how to deal with it now ?

I think there should be some documentations on the new doc website to indicate how to do this,

cheers,
David

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: How to install gems + vagrant 1.1 ?

David Cournapeau


On Mon, Mar 25, 2013 at 5:22 PM, Mitchell Hashimoto <[hidden email]> wrote:
David,


The windows plugin needs to be updated to be 1.1 compatible then you can do that.

Yep, I figured that out, sadly... I guess it is time to learn enough ruby to make that work on 1.1.

What was not clear from the doc is whether a local gem can be installed through the same mechanism as, but maybe that's just my English failing.

thanks,
David

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 
Reply | Threaded
Open this post in threaded view
|

Re: How to install gems + vagrant 1.1 ?

Mitchell Hashimoto



On Mon, Mar 25, 2013 at 10:28 AM, David Cournapeau <[hidden email]> wrote:


On Mon, Mar 25, 2013 at 5:22 PM, Mitchell Hashimoto <[hidden email]> wrote:
David,


The windows plugin needs to be updated to be 1.1 compatible then you can do that.

Yep, I figured that out, sadly... I guess it is time to learn enough ruby to make that work on 1.1.

What was not clear from the doc is whether a local gem can be installed through the same mechanism as, but maybe that's just my English failing.


Ah. Well, maybe I should add an aside about that for people transitioning from 1.0.x. I'm really trying to avoid any mention of the word "gem" except in the development docs because I want users to stop thinking of Vagrant as a Ruby project.

Best,
Mitchell
 
thanks,
David

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.
 
 

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/groups/opt_out.