Default Vagrant Provider Problems

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Default Vagrant Provider Problems

Kevin Stasko
I've recently switched to Windows 8.1 at the work place and with the recent vagrant update the default provider is hyperv. All of my VM's run on virtualbox and I have no desire to switch now. 

According to the Vagrant documentation it should be as simple as setting: ( https://docs.vagrantup.com/v2/providers/default.html )
VAGRANT_DEFAULT_PROVIDER = "virtualbox"

but it still insists on using hyperv as my default. Am I missing something here or does someone have any suggestions. Thank you ahead of time.

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Default Vagrant Provider Problems

Alvaro Miranda Aguilera

On Thu, May 29, 2014 at 4:47 AM, Kevin Stasko <[hidden email]> wrote:
AGRANT_DEFAULT_PROVIDER = "virtualbox"


try firstĀ  vagrant up --provider=virtualbox

if that fails it's due vboxmanage,etc are not in the path

the fist at the moment is add /c/program files<etc> path to the PATH inĀ  your .bas_profile

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Default Vagrant Provider Problems

VMTrooper
Is there an ini or conf file where this can be set?  I did a fresh install of the latest version of Vagrant and immediately installed the Fusion provider before running any VMs.

Fusion is now the default provider, which isn't a problem, but I was just curious how this was set seeing how I never set the environment variable before.

Thanks!

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Default Vagrant Provider Problems

Kevin Stasko
In reply to this post by Alvaro Miranda Aguilera
This worked! Thank you for your quick response.

On Wednesday, May 28, 2014 4:56:11 PM UTC-5, Alvaro Miranda Aguilera wrote:

On Thu, May 29, 2014 at 4:47 AM, Kevin Stasko <<a href="javascript:" target="_blank" gdf-obfuscated-mailto="-EORR6zJ7DAJ" onmousedown="this.href='javascript:';return true;" onclick="this.href='javascript:';return true;">kevin....@...> wrote:
AGRANT_DEFAULT_PROVIDER = "virtualbox"


try first  vagrant up --provider=virtualbox

if that fails it's due vboxmanage,etc are not in the path

the fist at the moment is add /c/program files<etc> path to the PATH in  your .bas_profile

--
You received this message because you are subscribed to the Google Groups "Vagrant" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
For more options, visit https://groups.google.com/d/optout.